 alg.exe

alg.exe

Местонахождение

WINDOWS\system32

Описание

Служба шлюза уровня приложения (Application Layer Gateway Service)

Оказывает поддержку протоколов третьей стороны протоколов PnP для общего доступа к подключению к Интернету и подключений к Интернету с использованием брандмауэра. Эта служба нужна при использовании Брандмауэра Интернета/Общего доступа к Интернету для подключения к интернету.

Значение по умолчанию | Рекомендуемое значение
Вручную | Вручную

Зависимости от данной службы

Брандмауэр Интернета (ICF) /Общий доступ к Интернету (ICS) (Internet Connection Firewall/Internet Connection Sharing)


 arp.exe

arp.exe

Местонахождение

Windows\system32

Описание

TCP/IP Arp Command

Команда Arp используется для просмотра, добавления или удаления записей в таблицах трансляции адресов IP в физические адреса. Эти записи используются при работе протокола Address Resolution Protocol (ARP)

Синтаксис

arp -a [inet_addr] [-N [if_addr]]
arp -d inet_addr [if_addr]
arp -s inet_addr ether_addr [if_addr]

Параметры

-a
Displays current ARP entries by querying TCP/IP. If inet_addr is specified, only the IP and physical addresses for the specified host are displayed.
-d
Deletes the entry specified by inet_addr.
-g
Same as -a
-s
Adds an entry in the ARP cache to associate the IP address inet_addr with the physical address ether_addr. The physical address is given as 6 hexadecimal bytes separated by hyphens. The IP address is specified using dotted decimal notation. The entry is static. It will not be automatically removed from the cache after the timeout expires and will not exist after a reboot of your computer.
-N [if_addr]
Displays the ARP entries for the network interface specified by if_addr.
ether_addr
Specifies a physical address.
if_addr
Specifies, if present, the IP address of the interface whose address translation table should be modified. If not present, the first applicable interface will be used.
inet_addr
Specifies an IP address in dotted decimal notation.


 at.exe

at.exe

Местонахождение

Windows\system32

Описание

Интерфейс командной строки службы расписаний - Schedule service command line interface

Команда At предназначена для запуска команд и программ в указанное время по определенным дням. Для использования команды AT необходимо, чтобы была запущена служба расписаний. Возможна работа с удаленными компьютерами. Для запуска задач пользователь должен обладать необходимыми правами.

Синтаксис

AT [\\имя_компьютера] [ [код] [/DELETE] | /DELETE [/YES]]
AT [\\имя_компьютера] время [/INTERACTIVE] [ /EVERY:день[,...] | /NEXT:день[,...]] "команда"

Параметры

\\имя_компьютера
Имя удаленного компьютера. Если этот параметр опущен, используется локальный компьютер.
код
Порядковый номер запланированной задачи.
/delete
Отмена запланированной задачи. Если код задачи опущен, отменяются все задачи, запланированные для указанного компьютера.
/yes
Отмена запроса на подтверждение при отмене всех запланированных задач.
время
Время запуска команды.
/interactive
Разрешение взаимодействия задачи с пользователем, работающим на компьютере во время запуска задачи.
/every:день[,...]
Запуск задачи осуществляется по указанным дням недели или месяца. Если дата опущена, используется текущий день месяца.
/next:день[,...]
Задача будет запущена в следующий указанный день недели (например в следующий четверг). Если дата опущена, используется текущий день месяца.
"команда"
Команда Windows NT или имя пакетного файла.


 attrib.exe

attrib.exe

Местонахождение

Windows\system32

Описание

Attribute Utility

Утилита командной строки позволяет просматривать, устанавливать или снимать атрибуты файла или каталога, такие как «Только чтение», «Архивный», «Системный» и «Скрытый». Выполненная без параметров команда attrib выводит атрибуты всех файлов в текущем каталоге.

Синтаксис

attrib [{+r|-r}] [{+a|-a}] [{+s|-s}] [{+h|-h}] [[диск:][путь] имя_файла] [/s[/d]]

Описание параметров есть в справке Windows


 Boot.ini

boot.ini

Местонахождение

C:\ (в корневой папке системного диска)

Описание

Файл boot.ini имеет очень много настроек. Microsoft посвятила описанию настроек в данном файле целую страницу на своем сайте. Оставляю описание почти без изменений. Если есть желание, то можете присылать переводы

Available switch options for the Windows XP and the Windows Server 2003 Boot.ini files

You can add many different switches to the Boot.ini file that will modify the way that Microsoft Windows XP or Microsoft Windows Server 2003 start.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

102873 Boot.ini and ARC path naming conventions and usage

MORE INFORMATION

You can add the following switches to the Boot.ini file.

Note These switches apply to Microsoft Windows XP and to Microsoft Windows Server 2003, unless otherwise specified.

/basevideo

The /basevideo switch forces the system into standard 640x480 16-color VGA mode by using a video driver that is compatible with any video adapter. This switch permits the system to load if you selected the wrong video resolution or refresh rate. Use this switch in conjunction with the /sos switch. If you install a new video driver, and it does not work correctly, you can use this parameter to start the operating system. You can then remove, update, or roll back the problem video driver.

/baudrate=number

This switch sets the baud rate of the debug port that is used for kernel debugging. For example, type /baudrate=9600. The default baud rate is 9600 kilobits per second (Kbps) if a modem is attached. The default baud rate is 115,200 Kbps for a null-modem cable. 9,600 is the normal rate for remote debugging over a modem. If this switch is in the Boot.ini file, the /debug switch is automatically enabled.

For additional information about modem configuration, click the following article number to view the article in the Microsoft Knowledge Base:

148954 How to set up a remote debug session using a modem

For additional information about null modem configuration, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/crashdebug

This switch loads the kernel debugger when you start the operating system. The switch remains inactive until a Stop message error occurs. /crashdebug is useful if you experience random kernel errors. With this switch, you can use the COM port for normal operations while Windows is running. If Windows crashes, the switch converts the port to a debug port. (This action turns on remote debugging.)

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/debug

This switch turns on the kernel debugger when you start Windows. The switch can be activated at any time by a host debugger that is connected to the computer, if you want to turn on live remote debugging of a Windows system through the COM ports. Unlike the /crashdebug switch, /debug uses the COM port whether you are debugging or not. Use this switch when you are debugging problems that are regularly reproducible.

For additional information about remote debugging, click the following article number to view the article in the Microsoft Knowledge Base:

121543 Setting up for remote debugging

/debugport=comnumber

This switch specifies the communications port to use for the debug port, where number is the communications port, such as COM1, that you want to use. By default, /debugport uses COM2 if it exists. Otherwise, the switch uses COM1. If you include this switch in the Boot.ini file, the /debug switch becomes active.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/maxmem=number

This switch specifies the maximum amount of RAM that Windows can use. Do not make this setting less than 12. Use this parameter to confirm whether a memory chip is faulty. For example, if you have a 128-megabyte (MB) system that is equipped with two 64-MB RAM modules, and you are experiencing memory-related Stop messages, you can type /maxmem=64. If the computer starts Windows and operates without problems, replace the first module to see if this action resolves the problem.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

108393 MAXMEM option in Windows NT Boot.ini file

/noguiboot

This switch disables the bitmap that displays the progress bar for Windows startup. (The progress bar appears just before the logon prompt.)

/nodebug

This switch turns off debugging. This scenario can cause a Stop error if a program has a debug hardcoded breakpoint in its software.

/numproc=number

This switch sets the number of processors that Windows will run at startup. With this switch, you can force a multiprocessor system to use only the quantity of processors (number) that you specify. This switch can help you troubleshoot performance problems and defective CPUs.

/pcilock

For x86-based systems, this switch stops the operating system from dynamically assigning hardware input, hardware output, and interrupt request resources to Peripheral Connect Interface (PCI) devices. With this switch, the BIOS configures the devices.

/fastdetect:comnumber

This switch turns off serial and bus mouse detection in the Ntdetect.com file for the specified port. Use this switch if you have a component other than a mouse that is attached to a serial port during the startup process. For example, type /fastdetect:comnumber, where number is the number of the serial port. Ports may be separated with commas to turn off more than one port. If you use /fastdetect, and you do not specify a communications port, serial mouse detection is turned off on all communications ports.

Note In earlier versions of Windows, including Windows NT 4.0, this switch was named /noserialmice.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

131976 How to disable detection of devices on serial ports

/sos

The /sos switch displays the device driver names while they are being loaded. By default, the Windows Loader screen only echoes progress dots. Use this switch with the /basevideo switch to determine the driver that is triggering a failure.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

99743 Purpose of the Boot.ini file in Windows 2000 or Windows NT

/PAE

Use the /PAE switch with the corresponding entry in Boot.ini to permit a computer that supports physical address extension (PAE) mode to start normally. In Safe Mode, the computer starts by using normal kernels, even if the /PAE switch is specified.

/HAL=filename

With this switch, you can define the actual hardware abstraction layer (HAL) that is loaded at startup. For example, type /HAL=halmps.dll to load the Halmps.dll in the System32 folder. This switch is useful to try out a different HAL before you rename the file to Hal.dll. This switch is also useful when you want to try to switch between starting in multiprocessor mode and starting in single processor mode. To do this, use this switch with the /kernel switch.

/kernel=filename

With this switch, you can define the actual kernel that is loaded at startup. For example, type /kernel=ntkrnlmp.exe to load the Ntkrnlmp.exe file in the System32 folder. With this switch, you can switch between a debug-enabled kernel that is full of debugging code and a regular kernel.

/bootlog

This switch turns on boot logging to a file that is named systemroot\Ntbtlog.txt. For more information about boot logging, see Windows Help.

/burnmemory=number

This switch specifies the amount of memory, in megabytes, that Windows cannot use. Use this parameter to confirm a performance problem or other problems that are related to RAM depletion. For example, type /burnmemory=128 to reduce the physical memory that is available to Windows by 128 MB.

/3GB

This switch forces x86-based systems to allocate 3 GB of virtual address space to programs and 1 GB to the kernel and to executive components. A program must be designed to take advantage of the additional memory address space. With this switch, user mode programs can access 3 GB of memory instead of the usual 2 GB that Windows allocates to user mode programs. The switch moves the starting point of kernel memory to 3 GB. Some configurations of Microsoft Exchange Server 2003 and Microsoft Windows Server 2003 may require this switch.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

823440 You must use the /3GB switch when you install Exchange Server 2003 on a Windows Server 2003-based system

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

171793 Information on application use of 4GT RAM tuning

/safeboot:parameter

This switch causes Windows to start in Safe Mode. This switch uses the following parameters:
  • minimal
  • network
  • safeboot:minimal(alternateshell)
You can combine other Boot.ini parameters with /safeboot:parameter. The following examples illustrate the parameters that are in effect when you select a Safe Mode option from the startup recovery menu.
  • Safe Mode with Networking
    /safeboot:minimal /sos /bootlog /noguiboot
  • Safe Mode with Networking
    /safeboot:network /sos /bootlog /noguiboot
  • Safe Mode with Command Prompt
    /safeboot:minimal(alternateshell) /sos /bootlog /noguiboot
Note The /sos, /bootlog, and /noguiboot switches are not required with any one of these settings, but the switches can help with troubleshooting. These switches are included if you press F8 and then select one of the modes.

/userva

Use this switch to customize the amount of memory that is allocated to processes when you use the /3GB switch. This switch permits more page table entry (PTE) kernel memory but still maintains almost 3 GB of process memory space.

For additional information about how to use the /USERVA switch, click the following article number to view the article in the Microsoft Knowledge Base:

316739 How to use the /USERVA switch in the Boot.ini file to tune /3GB configurations

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

810371 XADM: Using the /userva switch on Windows Server 2003-based Exchange Servers

323427 HOW TO: Manually edit the Boot.ini file in a Windows Server 2003 environment

317526 HOW TO: Edit the Boot.ini file in Windows Server 2003

317521 Description of the Bootcfg command and its uses

289022 HOW TO: Edit the Boot.ini file in Windows XP

291980 A discussion about the Bootcfg command and its uses

/redirect

Use this switch to turn on Emergency Management Services (EMS) on a Windows Server 2003, Enterprise Edition-based computer. For additional information about EMS, search on "Emergency Management Services" in Windows Help and Support.

To turn on EMS by editing the Boot.ini on an x86-based computer, edit both the [boot loader] section and the [operating systems] section of the Boot.ini file. To do this, configure the following entries:
  • Under [boot loader], add one of the following required statements:
    redirect=COMx
    In this statement, replace x with one of the following COM port numbers:

    1
    2
    3
    4

    redirect=USEBIOSSETTINGS
    This statement permits the computer BIOS to determine the COM port to use for EMS.
  • Under [boot loader], add the following option statement:
    redirectbaudrate=baudrate
    Replace baudrate with one of the following values:

    9600
    19200
    57600
    115200

    By default, EMS uses the 9600 Kbps baud rate setting.
  • Under [operating systems], add the /redirect option to the operating system entry that you want to configure to use EMS. The following example illustrates the use of these switches:
    [boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
redirect=COM1
redirectbaudrate=19200
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, EMS" /fastdetect /redirect

/channel

Use this switch together with the /debug switch and the /debugport switch to configure Windows to send debug information over an Institute of Electrical and Electronics Engineers, Inc. (IEEE) 1394 port. To support debugging over a 1394 port, both computers must be running Microsoft Windows XP or later. The 1394 port has a maximum number of 63 independent communications channels that are numbered 0 through 62. Different hardware implementations support a different number of channels across one bus. Windows XP has a limit of four destination computers. However, this limitation is removed in Windows Server 2003. To perform debugging, select a common channel number to use on both the computer that the debugger runs on, which is also known as the host computer, and the computer that you want to debug, which is also known as the destination computer. You can use any number from 1 to 62.

To configure the destination computer

  1. Edit the Boot.ini file to add the /CHANNEL=x option to the operating system entry that you have configured for debugging. Replace x with the channel number that you want to use. For example, configure the [operating systems] area of the Boot.ini file to look similar to the following:
    [boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect /debug /debugport=1394 /CHANNEL=3
  2. Plug the 1394 cable in one of the 1394 ports.
  3. Disable the 1394 host controller on the destination computer. To do this, start Device Manager, right-click the device, and then click Disable.
  4. Restart the computer.

To configure the host computer

  1. Plug the 1394 cable in one of the 1394 ports.
  2. Install the kernel debugger binary files.
  3. Start a command prompt. Press enter after you type each of the following commands:

    set_NT_DEBUG_BUS=1394
    set_NT_DEBUG_1394_CHANNEL=x
    kd -k

  4. Move to the folder where you installed the kernel debugger, and then type the following command:

    kd.exe

When you first start the debugger, a 1394 virtual driver is installed. This driver permits the debugger to communicate with the destination computer. You must be logged on with administrator rights for this driver installation to complete successfully.


 bootcfg.exe

bootcfg.exe

Местонахождение

Windows\system32

Описание

Средство конфигурации загрузки - Boot Config Tool

Программа bootcfg позволяет из командной строки управлять загрузочным меню, редактируя, добавляя или удаляя записи в файле boot.ini. Функции программы аналогичны ручному редактированию файла, однако, позволяют автоматизировать процесс настройки меню загрузки, использовать команды в .bat файлах.

Описание параметров есть в справке Windows


 charmap.exe

charmap.exe

Местонахождение

Windows\system32

Описание

Таблица символов - Character Map

Таблица символов служит для просмотра символов, включенных в выбранный шрифт. Она отображает следующие наборы символов: Windows, DOS и Юникод.

Отдельный символ или группу символов можно скопировать в буфер обмена, а затем вставить в любое приложение, в котором они будут отображаться. Многие программы, например WordPad, позволяют копировать символы путем их перетаскивания из таблицы символов непосредственно в открытый документ. Более подробное описание программы есть в справке


 ciadv.msc

ciadv.msc

Местонахождение

Windows\system32

Служба индексирования

Служба индексирования извлекает сведения из набора документов и собирает их в структуру, обеспечивающую быстрый и удобный доступ к этим сведениям с помощью команды Найти Windows XP, формы запроса службы индексирования или обозревателя. Эти сведения могут включать текст (содержимое) документа, характеристики и параметры (свойства) документа, такие как имя автора. После создания индекса можно запросить в нем документы, содержащие ключевые слова, фразы или свойства. Например, можно запросить все документы, содержащие слово «продукт», либо все документы Microsoft Office, созданные определенным автором. Служба индексирования возвращает список всех документов, соответствующих указанным условиям поиска.


 cleanmgr.exe

cleanmgr.exe

Местонахождение

WINDOWS\system32

Описание

Программа очистки дискового пространства для Windows - Disk Space Cleanup Manager for Windows

Программа очистки диска используется для освобождения пространства на жестком диске с помощью удаления временных файлов Интернета, установленных компонентов и программ, которые больше не используются, и очистки корзины. Программу можно запустить через Пуск-Все программы-Стандартные-Служебные-Очистка диска или через Пуск-Выполнить-cleanmgr


 clipbrd.exe

clipbrd.exe

Местонахождение

Windows\system32

Описание

Windows NT ClipBook Viewer

Программа папки обмена позволяет вырезать или копировать данные из других программ и хранить их на странице, которую можно сохранить под любым именем, использовать повторно и совместно с другими пользователями. Более подробное описание программы есть в справке


 Cmd.EXE

Cmd.EXE

Местонахождение

Windows\system32

Описание

Windows Command Processor

В Windows XP имеется так называемая консоль - программа Cmd.exe, которая является командным интерпретатором. При простом запуске, без указания параметров командной строки, консоль отображает версию операционной системы, информацию о защите авторских прав разработчиков ОС и саму командную строку, в которой можно ввести как параметр командной строки самой программы Cmd.exe, так и любую внешнюю команду, например, команду на запуск другого приложения или стандартную команду, типа mkdir, del и т. п.

Параметры командной строки

Синтаксис для командной строки:

CMD [/A | /U] [/Q] [/D] [/E:ON | /E:OFF] [/F:ON | /F:OFF] [/V:ON | /V:OFF]
[[/S] [/C | /K] команда]

Можно использовать одновременно несколько команд, используя между ними специальный разделитель - символы &&, при этом все сочетание нескольких команд должно быть заключено в кавычки, например, "команда&&команда&& команда".

/? - вызов справки
/A - вывод результатов выполнения заданной команды в формате ANSI
/C - выполнение заданной команды с последующим закрытием окна консоли
/D - отключение выполнения команд AutoRun (которые первыми автоматически выполняются при вызове cmd.exe), заданных в специальных разделах реестра HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun и HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun
/E:ON (/E:OFF) - разрешение (запрет) расширений команд. В Windows XP по умолчанию включена расширенная обработка всех команд cmd.exe, этот параметр служит для включения / выключения расширений конкретного процесса. Расширенная обработка включает следующие команды: assoc, call, chdir (cd), color, del (erase), endlocal, for, ftype, goto, if, mkdir (md), popd, prompt, pushd, set, setlocal, shift, start (изменен также вызов внешних команд)
/F:ON (/F:OFF) - разрешение (запрет) завершения имен файлов и папок (по умолчанию выключено) конкретного вызова cmd.exe. Довольно удобная функция, позволяющая не вводить полностью вручную в окне консоли пути к файлам или имена самих папок, а ввести только часть длинного пути и с помощью нажатия специальной комбинации клавиш дать операционной системе найти подходящие варианты и просто выбрать нужный. (Если необходимо включить или отключить завершение имен для всех вызовов cmd.exe). Параметры пользователя имеют приоритет над параметрами компьютера, значение параметра /F командного процессора имеет приоритет над параметрами реестра. Microsoft вносит некоторые разъяснения по поводу использования этой функции: "Если завершение включено с помощью ключа командной строки / F:ON, то используются два управляющих символа: Ctrl+D для имен папок и Ctrl+F для имен файлов. Чтобы отключить конкретный символ завершения в системном реестре, в качестве кода специального символа используется шестнадцатеричное значение символа пробела (0 x 20). Завершение вызывается при вводе одного из этих двух специальных символов. Функция завершения берет строку пути слева от точки ввода, дописывает к ней символ шаблона, если таковой отсутствует, а затем строит список путей, которые соответствуют полученному определению. После этого выводится первый элемент этого списка соответствующих путей. Если же список пуст, то подается звуковой сигнал, и ничего не выводится. После этого повторный ввод того же самого специального символа приводит к циклическому перебору всех соответствующих путей. Нажатие клавиши Shift при вводе управляющего символа позволяет просматривать список путей в обратном порядке. Если изменить выведенный путь, а затем снова ввести управляющий символ, сохраненный список очищается, и строится новый список путей. То же самое происходит, если переключиться с одного символа завершения на другой. Единственное отли чие при использовании символа завершения файла состоит в том, что при этом для построения списка соответствия берется и путь, и имя файла, а при использовании символа завершения папки - только путь. Если символ завершения используется в одной из встроенных команд манипулирования папками (CD, MD или RD), то всегда подразумевается символ завершения папок. Символ завершения правильно работает и с именами файлов, содержащими пробелы или иные специальные символы, если при этом строка соответствия заключена в кавычки. Кроме того, если сместить точку ввода влево, а затем использовать символ завершения внутри строки, оставшийся справа от точки ввода текст будет отброшен. Специальные символы, которые требуют обязательного заключения в кавычки: <пробел>&()[]{}^=;!'+,~". Все понятно?
/K - выполнение заданной команды без последующего завершения (окно консоли не закроется)
/Q - отключение вывода команд на экран (ECHO OFF). /R - аналогичен параметру /C
/S - изменение поведения команды после /C или /K
/T:цвет - задание цвета текста и фона окна консоли. Параметр цвет имеет значение в виде двух шестнадцатеричных чисел: первое определяет цвет фона окна, а второе - текста в окне. То есть результатом выполнения команды "CMD /T:7С" будут светло-красные буквы на белом фоне.
/U - вывод результатов выполнения команды в формате Unicode
/V:ON (/V:OFF) - разрешение (запрет) отложенного расширения переменных среды (для конкретного вызова cmd.exe) с применением восклицательного знака "!" в качестве разделителя. Например, /V:ON разрешает использовать !var! в качестве расширения переменной var во время выполнения. Синтаксис var служит для расширения переменных при вводе, что приводит совсем к другим результатам внутри цикла FOR. При включенном отложенном расширении переменных среды символ "!" (восклицательный знак) может использоваться для замены текущего значения переменной среды во время выполнения; /X - означает то же, что и ключ /E:ON, из соображений совместимости; /Y то же, что и /E:OFF. И еще несколько замечаний. Если указаны ключи /C или /K, то остальная часть командной строки после такого ключа обрабатывается как командная строка, а обработка символов кавычек (") ведется таким образом. Символы кавычек в командной строке сохраняются, если выполняются все перечисленные ниже условия: ключ /S отсутствует; есть ровно два символа кавычек; между ними нет других специальных символов, как то: &<>()@^|; между ними имеются один или несколько пробелов; строка, заключенная в кавычки, является именем исполняемого файла. В противном случае проверяется первый символ, и если он является символом кавычек, то он удаляется, также удаляется последний символ кавычек в командной строке, а весь текст после этого последнего символа кавычек сохраняется.

Таблица для задания цвета текста и фона окна консоли
0 - черный | 1 - синий | 2 - зеленый | 3 - голубой
4 - красный | 5 - лиловый | 6 - желтый | 7 - белый
8 - серый | 9 - светло-синий | A - светло-зеленый | B - светло-голубой
C - светло-красный | D - светло-лиловый | E - светло-желтый | F - ярко-белый
Кстати, цвет и другие настройки можно изменять и другим способом. Щелкните правой кнопкой мыши по строке заголовка окна и выберите пункт Свойства. Откроется окно с четырьмя вкладками, на которых будут доступны опции изменения настроек программы. Если вам не нравится стандартный черный экран командной строки, то на вкладке Color вам предлагается выбрать цвет экрана и текста либо из 16 стандартных цветов, для которых имеется соответствующие образцы, либо задав числовое значение цвета в формате RGB. На вкладке Layout настраивается размер окна и экранного буфера. Если в ранних ОС MS-DOS и Windows размер экрана оставался неизменным 25 строк в высоту и 80 символов в длину, и для вывода большего количества строк приходилось добавлять команду |more, то в системах NT и более поздних можно просто задать достаточно большой размер буфера экрана и пользоваться полосой прокрутки, что гораздо удобнее. Текст в окне командной строки Для копирования и вставки текста в окно командной строки обычные для Windows комбинации клавиш, такие как Ctrl+C, Ctrl+V, работать не будут. Для извлечения текста из буфера обмена вам придется вызвать меню, щелкнув правой кнопкой мыши по заголовку окна, и выбрать подменю Edit. Или же просто щелкните правой кнопкой по окну. Для копирования текста из окна выберите пункт Mark и мышью выделите нужный текст. Затем либо нажмите Enter, либо в том же меню выберите Copy. Если надо вставить какой-то текст в окно командной строки, обратитесь к команде Paste. Для повторного выполнения команды воспользуйтесь стрелками <<вверх>> и <<вниз >>, позволяющими перемещаться по списку выполненных команд. Для очистки экрана от текста служит директива cls.

Команды

TITLE - для изменения заголовка строки
TITLE [строка], где строка - это будущий заголовок окна командной строки (записывается без кавычек). После задания заголовка окна он может быть изменен только повторным вызовом команды TITLE. Использование данной команды может быть полезно в командных файлах. Так, выполнение примера, который приведен ниже, будет сопровождаться появлением соответствующей надписи в заголовке окна:

@ECHO OFF
TITLE Копируются файлы...
COPY \\Server\Share\*.doc C:\User\Common\*.doc
ECHO Копирование закончено.
TITLE Процесс завершен

Команда АТ - С помощью этой команды можно запускать команды и программы в определенное время.
AT [\\имя компьютера] [ [id] [/DELETE] | /DELETE [/YES]]
AT [\\имя компьютера] time [/INTERACTIVE] [ /EVERY:дата[,...] | /NEXT:дата [,...]] "команда"
\\имя компьютера указывает на удаленный компьютер, на котором могут быть запущены планируемые задачи. Если этот параметр не указан, то по умолчанию предполагается тот компьютер, на котором запускается команда АТ;
id идентификатор, назначенный указанной команде;
/delete отменяет намеченную команду. Если id опущен, все назначенные команды на компьютере отменены;
/yes этот параметр в случае использования с предыдущим параметром (/delete) автоматически включает подтверждение для всех запросов;
time время выполнения команды (в 24-часовом формате часы:минуты);
/interactive позволяет команде AT обмениваться с подключенными на данный момент в системе пользователями;
/every:дата[,...] выполняет команду в каждый указанный день (дни) недели или месяц. Если дата опущена, подразумевается текущий день месяца;
/next:дата[...] выполняет указанную команду при следующем наступлении указанной даты (например, в следующий четверг). Если дата не указанна, по умолчанию принимается текущий день месяца;
"команда" указывается команда Windows NT или пакетная программа, которая будет выполнена. Имя файла должно указываться полностью. При этом, если выполняется какая-либо из внутренних команд, например, COPY или DIR, а не исполняемый файл, то необходим запуск командного интерпретатора с ключом / С, например: AT 10:00 "CMD /C DIR > C:\test.out.
Команда For - Ее возможности обширны, но мы ограничимся демонстрацией лишь одной из них - Копирование по сети на все машины сразу. Допустим, что требуется скопировать файл на двадцать машин. Делается это очень быстро. Сначала в файл list.txt записываем список всех имеющихся в сети машин. В консоли пишем:

net view > c:\list.txt
Затем, чтобы выполнить, например, копирование файла patch.exe на каждую машину из списка, даем команду:
FOR /F "tokens=1" %i in (с:\list.txt) do copy d:\temp\patch.exe "%i\C$\program files\ICQ"
Переменная %i будет автоматически принимать значение NetBIOS-имени машины из новой строки файла list.txt и на эту машину будет производиться копирование.

Реестр

Изменение вида приглашения командной строки


 convert.exe

convert.exe

Местонахождение

Windows\system32

Описание

File System Conversion Utility

Утилита командной строки служит для преобразования томов с файловой системой FAT и FAT32 в тома с файловой системой NTFS.

Синтаксис

convert [том] /fs:ntfs [/v] [/cvtarea:имя_файла] [/nosecurity] [/x]

Описание параметров есть в справке Windows


 cscript.exe

cscript.exe

Местонахождение

Windows\system32

Описание

Microsoft (r) Console Based Script Host

Сервер сценариев cscript.exe является консольным вариантом, предназначенный для взаимодействия с пользователем через командную строку (в отличии от GUI-приложения wscript.exe).

Синтаксис

cscript [имя_сценария] [параметры_сервера] [аргументы_сценария]

Описание параметров есть в справке Windows


 defrag.exe

defrag.exe

Местонахождение

Windows\system32

Описание

Disk Defragmenter Module

Поиск и объединение фрагментированных файлов загрузки, файлов данных и папок на локальных томах.

Синтаксис

defrag том
defrag том [/a]
defrag том [/a] [/v]
defrag том [/v]
defrag том [/f]

Описание параметров есть в справке Windows


 diskpart.exe

diskpart.exe

Местонахождение

Windows\system32

Описание

Diskpart Application

Программа DiskPart.exe — это работающий в текстовом режиме командный интерпретатор, который позволяет управлять объектами (дисками, разделами или томами) с помощью сценариев или команд, вводимых с командной строки.

Синтаксис

diskpart [/add | /delete] [имя_устройства | имя_диска | имя_раздела] [размер]

Описание программы есть в справке Windows


 drwtsn32.exe

drwtsn32.exe (Доктор Ватсон в Windows)

Местонахождение

Windows\system32

Описание

DrWatson Postmortem Debugger

Программа Доктор Ватсон (Drwtsn32.exe) устанавливается в системную папку при установке Windows. Параметры, используемые по умолчанию, задаются при первом запуске программы «Доктор Ватсон», который выполняется при возникновении программной ошибки или по команде пользователя.

При возникновении программной ошибки в Windows система выполняет поиск обработчика программных ошибок. Он обрабатывает ошибки по мере их возникновения во время выполнения программы. Если найти обработчик не удается, система проверяет, чтобы приложение не находилось в режиме отладки, после чего рассматривает ошибку как не подлежащую обработке. Далее система ищет отладчик программных ошибок в системном реестре и обрабатывает такие ошибки.

Более подробное описание программы ищите в справке Windows


 eventvwr.msc

eventvwr.msc

Местонахождение

Windows\system32

Просмотр событий (Event Viewer)

В окне просмотра событий ведутся журналы программных, системных событий, а также событий безопасности на компьютере. Окно просмотра событий используется для просмотра журналов событий и управления ими, получения сведений о неполадках аппаратного и программного обеспечения, а также для наблюдения за событиями безопасности Windows.


 explorer.exe

explorer.exe

Местонахождение

Windows

Описание

Проводник - Windows Explorer

Одна из основных программ Windows для навигации по папкам и дискам

Ключи командной строки Проводника

  • /e - Вид Проводника по умолчанию (двухпанельное), иначе выводится как однопанельное (как Папка).
  • /e, object - Открывается Проводник с видом по умолчанию и с фокусом на заданной папке (Explorer /e,C:\Windows)
  • /n - Открытие однопанельного нового окна на диске, на котором установлена система (C:\). Иначе информация выводится в существующем окне Проводника, если оно открыто.
  • /root, object - Указывает на то, что корнем будет object - это дисковод (сетевой или локальный) или папка. Иначе корнем считается Рабочий стол. (Explorer /root, C:\Windows\Cursors)
  • /select, object - Указывает на необходимость открытия Родительской папки объекта object и выделит object (Explorer /select, C:\Windows\Cursors\banana.ani).


 fc.exe

fc.exe

Местонахождение

Windows\system32

Описание

DOS 5 File Compare Utility

Утилита командной строки для сравнения двух файлов и вывода различий между ними

Синтаксис

fc [/a] [/b] [/c] [/l] [/lbn] [/n] [/t] [/u] [/w] [/nnnn] [диск1:][путь1]имяфайла1 [диск2:][путь2]имяфайла2

Описание параметров есть в справке Windows


 find.exe

find.exe

Местонахождение

Windows\system32

Описание

Find String (grep) Utility

Поиск заданной строки текста в файле или нескольких файлах. После поиска в заданных файлах команда find выведет на экран все строки из этих файлов, содержащие заданный образец.

Синтаксис

find [/v] [/c] [/n] [/i] "строка" [[диск:][путь]ИмяФайла[...]]

Описание параметров есть в справке Windows


 fsmgmt.msc

fsmgmt.msc

Местонахождение

Windows\system32

Общие папки (Shared Folders)

Компонент «Общие папки» может быть использован для управления общими ресурсами по сети. При помощи компонента «Общие папки» можно осуществлять контроль над разрешениями учетных записей пользователей, сеансами и свойствами общих ресурсов.


 fsutil.exe

fsutil.exe

Местонахождение

Windows\system32

Описание

fsutil.exe

Fsutil является служебной программой командной строки, которая используется для выполнения связанных задач файловых систем FAT и NTFS, таких как управление точками повторной обработки, управление разреженными файлами, отключение тома или расширение тома. Поскольку программа fsutil является весьма мощной, ее должны применять только опытные пользователи, имеющие опыт работы с Microsoft Windows XP. Для использования программы fsutil необходимо войти в систему с помощью учетной записи администратор или члена группы администраторов.

Описание программы и ее подкоманд есть в справке Windows.

Для отображения справки о подкомандах утилиты используйте команду

fsutil подкоманда help

Применение

С помощью утилиты командной строки fsutil можно создать файл с заданным размером. Например, вам надо создать файл sample.txt размером 1 кб, не заботясь о его содержании. Делаем так:

fsutil file createnew FileName Size
где FileName - имя файла (sample.txt, или c:\folder\sample.txt), а Size - размер файла в байтах.


 ftp.exe

ftp.exe

Местонахождение

Windows\system32

Описание

File Transfer Program

Позволяет передавать файлы с компьютера и на компьютер с помощью программ, поддерживающих протокол FTP (File Transfer Protocol)

Синтаксис

ftp [-v] [-d] [-i] [-n] [-g] [-s:имя_файла] [-a] [-w:размер] [-A] [Ведомый компьютер]

Описание параметров есть в справке Windows


 hostname.exe

hostname.exe

Местонахождение

Windows\system32

Описание

Hostname APP

Утилита командной строки hostname выводит имя системы, на котором была запущена эта команда

Синтаксис

hostname

У данной команды нет параметров


 HTA-файлы

HTML-приложения

Начиная с Internet Explorer 5.0 появилась возможность создавать HTML-приложения с любым пользовательским интерфейсом при помощи JavaScript или VBScript. Причем, созданное html-приложение будет запускаться вне браузера и ничем не будет отличаться от стандартных Windows-приложений.

Созданное приложение будет присутствовать на панели задач, иметь свое собственное окно, меню и значок. Плюс ко всему отпадает необходимость подтверждать использование ActiveX-компонентов (система защиты Internet Explorer предусматривает появление предупреждающих сообщений при попытке использования ActiveX в HTML-документах). Вы имеете полный контроль над системой, включая чтение/запись файлов, данных в реестре, управление процессами. Для создания такого приложения достаточно обычного Блокнота (или другой текстовый редактор).

Данные html-приложения должны иметь расширение *.hta. Простейший случай будет выглядеть так:

Создайте подобный файл и запустите его. Как видите, появившееся окно ничем не напоминает браузер, однако вы можете использовать такую возможность, например, как Refresh документа (в нашем случае это главное окно будущего приложения) или изменение кодировки на лету. Для удаления полосы прокрутки мы воспользовались параметром SCROLL=no в тэге BODY, можно также воспользоваться специальными свойствами тэга HTA.

HTA-файлы обрабатывается программой mshta.exe, задача которой - обеспечить связь вашей программы с браузером.

Для того чтобы полностью использовать новые возможности, необходимо включить тэг HTA:APPLICATION между тэгами HEAD.

Как видно из приведенного примера, в тэге HTA:APPLICATION мы определяем специфические для HTA параметры. Рассмотрим их подробнее.

  • ID - идентификатор, который позволяет обращаться к нему как к объекту в скриптах

    Например:

  • APPLICATIONNAME - возвращает имя вашего приложения. Должно быть уникальным.

  • BORDER - позволяет задать тип окантовки окна. Доступны следующие значения:

    thick — толстая рамка, позволяющая изменять размер окна;

    dialog — обычная рамка без возможности изменять размер;

    none — рамка отсутствует;

    thin — тонкая без возможности изменять размер;

    Дополнительно указывается стиль рамки при помощи атрибута BORDERSTYLE, который может иметь следующие значения:

    normal — обычная;

    raised — приподнятая (3D);

    complex — комбинация стилей raised и sunken;

    static — может использоваться для окон, в которых не предусмотрен пользовательский ввод, - к примеру, для создания «флэш»-окон;

    sunken — вдавленная (3D).

  • CAPTION - определяет, будет ли окно отображаться с заголовком. Может принимать значения yes или no.
  • ICON - путь к файлу, содержащему значок (*.ico), содержащий картинку 32х32 пикселя. Можно использовать в качестве иконки и обычный bmp-файл - главное, чтобы соблюдались размеры картинки.
  • SHOWINTASKBAR - если это свойство имеет значение yes, окно будет сворачиваться в панель задач, а также отображаться на Панели задач
  • SINGLEINSTANCE - позволяет разрешить запуск только одной копии вашего приложения; для того чтобы определить, запущенно ваше приложение во второй раз или нет, это свойство использует APPLICATIONNAME. Может принимать значения yes/no.
  • SYSMENU - будет ли отображаться системное меню.
  • WINDOWSTATE - определяет, в каком виде приложение будет стартовать.

    Принимает следующие значения:

    normal — обычное окно.

    minimize — свернуто.

    maximize — на весь экран.

  • MAXIMIZEBUTTON и MINIMIZEBUTTON принимают значения yes/no и отвечают за отображение кнопок Maximize и Minimize соответственно в заголовке окна.

Помимо атрибутов, характеризующих внешний вид программы, может быть задана версия продукта — например, так:

Для управления полосой прокрутки в окне HTA есть целых два параметра: SCROLL со значениями yes/no/auto и SCROLLFLAT — yes/no.

Если у вас установлен IE5.5, то вы можете воспользоваться дополнительным атрибутом NAVIGABLE, который позволяет переход по ссылке в окне HTA.

Для управления текстом предусмотрен параметр SELECTION (yes/no).

В дополнение ко всему перечисленному, вы можете иметь доступ к параметрам командной строки посредством свойства commandLine. Внимание, это свойство не имеет HTML-синтаксиса и может быть доступно только из скриптов! Немаловажно заметить, что все перечисленные параметры во время выполнения доступны только для чтения.

Давайте приступим к написанию своего первого скриптового приложения - создадим простейший текстовый редактор.

Константы для работы с диалогами открытия и сохранения файлов:

CdlOFNFileMustExist — пользователь может вводить только имя существующего файла, в противном случае возникнет предупреждение.

CdlOFNHideReadOnly — прячет опцию Hide Only (открыть только для чтения).

Константы для работы с файлами:

ForReading — файл открывается для чтения;

ForWriting — для записи в файл.

Создаем объект для доступа к файловой системе:

И настраиваем общие свойства для диалога открытия и сохранения:

Заголовок диалога:

Фильтр, для отображения групп файлов.

Вызываем диалог открытия и в случае если пользователь осуществил выбор пытаемся прочитать файл и отобразить его.

Естественно, дополнительными тэгами все вкусности скриптовых приложений не исчерпываются. Особую ценность представляет возможность повторного использования однажды написанного кода, создание универсальных компонентов, с которыми можно работать аналогично COM-компонентам.


 iexpress.exe

iexpress.exe

Местонахождение

Windows\system32

Описание

Wizzard

В Windows XP есть простейший инстяллятор файлов IExpress. Удобный диалог, упаковывает файлы в exe-файлы, один минус: не руссифицирован. Причем, например, 2 десятка картинок сжимаются даже лучше чем в WinRAR 3.0


 INF-файлы

INF-файлы

В данной статье мы рассмотрим, что представляет собой INF-файл, как с его помощью работать с другими файлами и реестром, создавать ярлыки, запускать программы и т.д.

Как известно, для более-менее серьезного программного продукта обычно требуется специальная программа инсталляции, с помощью которой пользователь сможет легко установить и так же легко удалить сам продукт. Существует много инструментальных средств, позволяющих быстро создавать инсталляционные пакеты. Однако, большинство из них добавляют к исходному размеру программы 200–500 Кб. А ведь это далеко не всегда радует. Серьезный продукт не обязательно должен быть внушительных размеров. И если вы хотите сделать инсталляцию доступной в Сети, то эти 200–500 Кб могут сильно сказаться на популярности продукта.

Как выйти из подобной ситуации? Здесь на помощь придут inf-файлы. Именно с помощью inf-файлов можно удалять, копировать другие файлы, добавлять информацию в реестр, в ini-файлы, создавать ярлыки, в общем, все то же, что обеспечивают громоздкие программы установки.

Перейдем к изучению спецификации inf-файлов.

inf-файл представляет собой текстовый файл, который, содержит условия установки программного обеспечения.

Чтобы запустить inf-файл, нужно щелкнуть по нему правой кнопкой мыши и выбрать в открывшемся контекстном меню параметр Установить (Install). Но для подготовки дистрибутива можно воспользоваться IExpress, который поддерживает запуск .inf-файлов. Вооружившись этой программой, а также знанием спецификации .inf-файлов, можно создавать профессиональные инсталляционные пакеты.

Основную информацию в .inf-файле содержат секции, представленные в Таблице 1 (более сложные .inf-файлы могут иметь дополнительные секции).

Секция [Version] обязательно должна включать строку

Эта секция определяет стандартный заголовок для всех inf-файлов Microsoft Windows. Если сигнатура будет не $Chicago$, операционная система Windows не примет inf-файл как принадлежащий любому из классов устройств, признанных Windows.

При написании сигнатуры вы можете использовать как верхний, так и нижний регистры букв — $Chicago$ или $CHICAGO$.

Секция установки [DefaultInstall] может содержать следующие параметры:

CopyFiles — копирование файлов;

RenFiles — переименование файлов;

DelFiles — удаление файлов;

UpdateInis — изменение данных в ini-файлах;

UpdateIniFields — изменение областей в .ini-файлах;

AddReg — добавление информации в реестр;

DelReg — удаление информации из реестра;

Ini2Reg — перемещение строки или секции в ini-файлах;

UpdateCfgSys — изменение файла Config.sys;

UpdateAutoBat — изменение файла Autoexec.bat.

Этим параметрам в качестве значения присваивается имя секции с файлами. Например:

Чуть ниже представлены цифровые обозначения специальных папок, применяемые в .inf-файлах:

10 — C:\WINDOWS;

11 — C:\WINDOWS\System;

12 — C:\WINDOWS\SYSTEM\IOSUBSYS;

13 — C:\WINDOWS\COMMAND;

17 — C:\WINDOWS\Inf;

18 — C:\WINDOWS\Hlp;

20 — C:\WINDOWS\FONTS;

21 — C:\WINDOWS\SYSTEM\VIEWERS;

22 — C:\WINDOWS\SYSTEM\VMM32;

23 — C:\WINDOWS\SYSTEM\COLOR;

30 — Корневой загрузочный диск (обычно C:\).

Например, если нужно скопировать файл в папку Web, которая находится в каталоге Windows, сделайте это так:

Так же можно поступить и с другими папками, находящимися в определенных каталогах.

Параметр CopyFiles содержит имя секции, где находятся имена файлов для копирования с исходного диска в папку назначения. Папка назначения определяется в секции [DestinationDirs] inf-файла. В следующем примере копируются два файла:

Цифры через три запятые обозначают дополнительные флаги при копировании файлов и могут принимать значения, представленные в

Параметр CopyFiles может копировать файл непосредственно из строки. Для этого перед именем файла нужно поставить символ @. В следующем примере копируются два текстовых файла:

Параметр RenFiles содержит секции, которые в свою очередь содержат имена файлов для переименования. Папка, где будет происходить переименование, должна быть определена в секции [DestinationDirs] inf-файла. В следующий примере происходит переименование двух файлов из .bmp в .txt:

Все старые имена файлов (Example1.bmp, Example2.bmp) должны быть определены в секции [SourceDisksFiles].

Параметр DelFiles содержит секции, которые содержат имена файлов для удаления. Папка, где будет происходить удаление, как всегда, должна быть определена в секции [DestinationDirs] .inf-файла. Следующий пример удаляет два файла:

В параметре AddReg указываются секции, которые содержат информацию о добавлении или изменении ключей, значений в реестре. Следующий пример регистрирует вашу копию операционной системы Windows.

С помощью этого файла в реестр добавляется следующая информация:

Обратите внимание на запятые в inf-файле. Если нужно добавить в реестр параметр по умолчанию, запятые должны быть проставлены иначе. Например, в рассмотренном нами ключе реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion сделаем параметр по умолчанию равным единице (1):

Ниже представлены корневые имена реестра, применяемые в inf-файлах.

HKCR — HKEY_CLASSES_ROOT;

HKCU — HKEY_CURRENT_USER;

HKLM — HKEY_LOCAL_MACHINE;

HKU — HKEY_USERS;

HKR — относительный ключ, используется классом installer; обычно применяется для дисков устройства.

В параметре DelReg указываются секции, которые содержат информацию об удалении подключей с параметрами и значениями из реестра. Следующий пример демонстрирует удаление подключа Graphviz со всеми параметрами и значениями этого раздела реестра — HKEY_CURRENT_USER\Software\AT&T\Graphviz:

Корневые имена реестра, естественно, обозначаются так же, как и при добавлении информации в реестр.

В процессе установки можно прервать выполнение .inf-файла для показа пользователю какого-нибудь документа (после закрытия которого установка продолжится) или запустить определенный процесс. Следующий пример отображает файл справки About.hlp и текстовый файл About.txt, после чего запускает другой inf-файл — Example.inf:

После того как определенные в секции [ExampleView] команды выполнятся, записи, добавленные в реестр, будут автоматически удалены из него. Таким образом можно запускать и другие процессы, например апплеты Панели управления:

В следующем примере показано, как с помощью inf-файла изменить содержимое ini-файла:

С помощью inf-файлов можно также создавать/удалять ярлыки в меню Пуск. Ярлык можно создать в уже созданной группе программ. Если таковой не существует, она будет создана автоматически.

Следующий пример создает группу программ Windows + + в меню Пуск > Программы и ярлыки к утилитам winipcfg.exe (Конфигурация IP), Regedit.exe (Редактор реестра) и Winfile.exe (Диспетчер файлов — только в Win98). Все они есть у вас на компьютере и лежат в папке Windows.

Ярлык прописывается в таком порядке:

1. Название группы программ. В нашем случае — Windows + +.

2. Имя ярлыка.

3. Путь к программе, к которой создается ярлык.

4. Рабочий каталог, обычно тот же, что и путь. Некоторые программы не работают, если это условие не выполняется.

5. Имя программы с расширением.

Параметр %30%\ определяет корневой диск. Если вы хотите создать ярлык к файлу, который находиться в каталоге Program Files, смело прописывайте полный путь (не используйте короткие имена), например %30%\Program Files\Setup Generator Pro\Sgpro.exe.

Для удаления ярлыка нужно убрать все записи, указанные после имени ярлыка. В следующем примере удаляется ярлык Конфигурация IP из программной группы Windows + +.

Если вы удаляете один из ярлыков программной группы, то удаление не затронет другие ярлыки. Для полного удаления программной группы нужно прописать данное действие для каждого ярлыка.

К сожалению, вы не сможете с помощью inf-файла обычным способом скопировать файлы с длинными именами. Поддержка длинных файловых имен в .inf-файлах немного усложнена, но главное, что она существует. Для этого нужно проделать следующее: исходный файл должен быть с коротким именем, после установки его имя нужно сделать подлиннее. Для удаления процесс повторяется в обратном порядке: длинное файловое имя делается коротким и удаляется уже файл с 8.3-именем. Происходит все это с помощью реестра. Для этих действий в реестре предусмотрены специальные ключи:

Для действий переименования или удаления нужно добавить подключ с любым именем в соответствующую ветвь реестра. Минимум два ключа должны быть определены. Первый ключ содержит имя каталога, где будет происходить переименование или удаление файлов. Следующий ключ содержит имена файлов: первое — короткое, второе — длинное и его атрибуты, если нужно:

1 — Только для чтения;

2 — Скрытый;

3 — Системный.

Следующий пример демонстрирует переименование в каталоге C:\Files файла About.txt в About View files.txt и установление ему атрибута «Скрытый», а также переименование того же файла в подкаталоге Xmp папки C:\Files с установлением ему атрибута «Только для чтения»:

Ключи для удаления файлов имеют такую же структуру. Рассмотрим пример, который в каталоге C:\Files удаляет файл About View files.txt и такой же файл удаляет в подкаталоге Xmp папки C:\Files:

Параметры Example и SubDir могут быть любыми, например названием вашей программы, подкаталога и т.д. Важно, чтобы они были разными, т.к. переименование/удаление происходит в разных каталогах.

Данная статья не претендует на полноту, но надеюсь, поможет читателю освоить inf-файлы хотя бы поверхностно. Не бойтесь экспериментировать, но будьте предельно осторожны, особенно с процессами удаления.


 ipconfig.exe

ipconfig.exe

Местонахождение

Windows\system32

Описание

IP Configuration Utility

Утилита командной строки Ipconfig служит для отображения всех текущих параметров сети TCP/IP и обновления параметров DHCP и DNS. При вызове команды ipconfig без параметров выводится только IP-адрес, маска подсети и основной шлюз для каждого сетевого адаптера

Синтаксис

ipconfig [/all] [/renew [адаптер]] [/release [адаптер]] [/flushdns] [/displaydns] [/registerdns] [/showclassid адаптер] [/setclassid адаптер [код_класса]]

Описание параметров есть в справке Windows


 lpq.exe

lpq.exe

Местонахождение

Windows\system32

Описание

TCP/IP Lpq Command

Служит для отображения состояния очереди печати на компьютере, использующем программное обеспечение сервера печати Line Printer Daemon (LPD). При вызове команды lpq без параметров в командной строке отображается справка по этой команде

Синтаксис

lpq -S имя_сервера -P имя_принтера [-l]

Описание параметров есть в справке Windows


 makecab.exe

makecab.exe

Местонахождение

WINDOWS\system32

Описание

Microsoft® Cabinet Maker

Утилита командной строки makecab.exe служит для создания cab-файлов

Для получения списка параметров используйте ключ makecab /?


 migwiz.exe

migwiz.exe

Местонахождение

WINDOWS\system32\usmt

Описание

Мастер переноса файлов и параметров - Files and Settings Transfer Wizard

Очень удобная утилита для переноса файлов и параметров различных программ с одного компьютера на другой. Например, вы легко перенесете все настройки и письма из Outlook Express. Программу можно запустить через Пуск-Все программы-Стандартные-Служебные-Мастер переноса файлов и параметров или через Пуск-Выполнить-migwiz


 mmc.exe

mmc.exe

Местонахождение

Windows\system32

Описание

Консоль управления (MMC) - Microsoft Management Console

Консоль MMC (Microsoft Management Console) группирует средства администрирования, которые используются для администрирования компьютеров, служб, других системных компонентов и сетей. Впервые она появилась в Windows 2000. Чтобы запустить ее, проделайте следующее:
Пуск->Выполнить->mmc. Перед вами откроется окно.

Дальше необходимо добавить групповую политику "Локальный компьютер", где и будут проводиться все настройки. Для этого выберите пункт меню Консоль->Добавить или удалить оснастку..., в появившемся окне нажмите кнопку "Добавить", и из появившегося диалога "Добавить изолированную оснастку" выберите "Групповая политика". Нажмите последовательно кнопки "Готово", "Закрыть", "ОК".

Давайте попробуем убрать пункт "Выполнить" из меню "Пуск" с помощью этого инструмента. В левой части окна консоли перед вами древовидная структура настраиваемых параметров операционной системы. Откройте пункт меню Конфигурация пользователя->Административные шаблоны->Панель задач и меню "Пуск". В расширенном варианте отображения данных вы сможете почитать описание настраиваемого пункта. Если вы знаете что именно вам надо настроить, то лучше переключиться в стандартный режим, чтобы не занимать лишнее место на экране монитора ненужной вам информацией. Итак, найдите строку Удалить команду "Выполнить" из меню "Пуск".

Дважды кликните по ней левой кнопкой мыши, отметьте пункт "Включен" и нажмите "ОК". Теперь если вы выберите Пуск->Выполнить, то увидите сообщение, что операция отменена вследствие действующих для компьютера ограничений. После перезагрузки этот пункт вообще пропадет из меню "Пуск". Аналогичным образом можно настроить и другие параметры меню "Пуск" и не только. Значения "Включен" и "Отключен" показывают действует или нет данная политика, а значение "Не задан" возвращает настройку политики в значение по умолчанию, заложенное в операционной системе. Вы наверняка уже обратили внимание на большое количество параметров, которые можно настроить с помощью оснастки MMC. Действительно, здесь можно настроить очень многие параметры операционной системы без использования дополнительных инструментальных средств. Описывать их все нет смысла, так что если вас заинтересовал этот способ твикинга, ознакомьтесь с ними самостоятельно, тем более описание настраиваемых параметров дает более чем исчерпывающую информацию. Ну, а для начального знакомства с оснасткой MMC приведенных сведений должно хватить.

Оснастки

  • Диспетчер устройств
  • Локальные пользователи и группы - Local Users and Groups
  • Общие папки
  • Производительность
  • Просмотр событий
  • Служба индексирования
  • Службы
  • Съемные ЗУ
  • Управление дисками - Disk Management
  • Управление компьютером


 msconfig.exe

msconfig.exe (Настройка системы)

Местонахождение

WINDOWS\PCHealth\HelpCtr\Binaries

Описание

System Configuration Utility

После загрузки появляется окно с шестью вкладками:
- Общие - позволяет управлять параметрами запуска системы.
- Config.sys - редактирование файла config.sys.
- Autoexec.bat - соответственно.
- System.ini.
- Win.ini.
- Автозагрузка - здесь перечислены все программы, которые запускаются при загрузке системы.
Очень удобно то, что все собрано в одном месте. Не надо лазить по реестру и файлам, чтобы посмотреть, что загружается на компьютере. Можно отключить загрузку любой программы или выполнение строки одного из перечисленных файлов, не правя ничего вручную. При этом комментарии будут расставлены автоматически, а программы, запускаемые из реестра, например, из раздела "Run", будут перенесены в раздел "Run-" (в конце соответствующего раздела добавляется символ "-").

Более подробное описание программы есть в справке самой программы

Реестр

Удаление ненужных записей


 msinfo32.exe

msinfo32.exe (Сведения о системе)

Местонахождение

C:\Program Files\Common Files\Microsoft Shared\MSInfo

Описание

System Information

Программа Сведения о системе собирает и отображает данные о конфигурации системы как для локальных, так и для удаленных компьютеров. Сюда входит информация о конфигурации оборудования, компонентах компьютера, а также программном обеспечении, в том числе о подписанных и неподписанных драйверах. При устранении неполадок, связанных с конфигурацией системы, сотрудникам службы технической поддержки необходимы определенные данные о компьютере. Программа «Сведения о системе» позволяет быстро собрать необходимые данные.

Для хранения данных о системе предназначены файлы с расширением .nfo. Кроме того, программа «Сведения о системе» работает с файлами форматов .cab и .xml. Содержимое открытого файла .cab можно просматривать средствами меню Сервис.

Синтаксис

msinfo32 [/?] [/pch] [/nfo имя_файла] [/report имя_файла] [/computer имя_компьютера] [/showcategories] [/category код_категории] [/categories код_категории]

Описание программы есть в справке Windows


 mspaint.exe

mspaint.exe

Местонахождение

Windows\system32

Описание

Paint

Оказывается, в Microsoft Paint можно быстро увеличить картинку аж в 10 раз. Для этого активизируйте инструмент Лупа. В нижней части поля, где фиксируется степень увеличения, находится тонкая белая линия. Аккуратно щелкните по ней. Как себя чувствует ваша картинка?

Если при работе в Paint, во время рисования линии удерживать нажатой клавишу Shift, то будет рисоваться прямая линия. Если проводить линию под углом, то при этом угол будет составлять 45 градусов.

А если удерживать нажатой клавишу Shift при рисовании фигур, то будет рисоваться квадраты и круги, вместо прямоугольников и эллипсов.


 net.exe

net.exe

Местонахождение

Windows\system32

Описание

Net Command

В утилите net.exe реализовано множество команд для управления различными сетевыми компонентами, такими, как разделы, сессии, службы и учетные записи пользователей. Например, с помощью команды net User можно получить информацию о группах, к которым принадлежит пользователь.

Для более подробной информации наберите в командной строке:

net /?


 netstat.exe

netstat.exe

Местонахождение

Windows\system32

Описание

TCP/IP Netstat Command

Отображение активных подключений TCP, портов, прослушиваемых компьютером, статистики Ethernet, таблицы маршрутизации IP, статистики IPv4 (для протоколов IP, ICMP, TCP и UDP) и IPv6 (для протоколов IPv6, ICMPv6, TCP через IPv6 и UDP через IPv6). Запущенная без параметров, команда nbtstat отображает подключения TCP.

Синтаксис

netstat [-a] [-e] [-n] [-o] [-p протокол] [-r] [-s] [интервал]

Описание программы есть в справке Windows

Чтобы вывести все активные подключения, отсортированные по возрастанию номера порта, необходимо набрать:

netstat -n


 nslookup.exe

nslookup.exe

Местонахождение

Windows\system32

Описание

nslookup APP

Предоставляет сведения, предназначенные для диагностики инфраструктуры DNS. Для использования этого средства необходимо быть знакомым с принципами работы системы DNS. Средство командной строки Nslookup доступно, только если установлен протокол TCP/IP

Синтаксис

nslookup [-подкоманда ...] [{искомый_компьютер| [-сервер]}]

Описание параметров есть в справке Windows


 oeminfo.ini

oeminfo.ini

Местонахождение

Windows\system32

Описание

Если создать текстовый файл oeminfo.ini и поместить его в системную папку Windows (как правило Windows\system32), то в апплете Система Панели управления, появится кнопка Сведения о поддержке

Файл oeminfo.ini имеет следующую структуру:

[General]
Manufacturer=Название компании
Model=Название модели
[Support Information]
Line1=За поддержкой обращайтесь по телефону 03
Line2=Бла-бла-бла
Line3=Часы работы:
Line4=Понедельник-Пятница 08.00-16.00
Line5=Суббота-Воскресенье 11.00-12.00!
Line6=Всего шесть строчек

Строго говоря, данный файл не присутствует на чистом инсталяционном диске Windows, но может входить в Windows, который предустановлен на компьютерах различных производителей, имеющих соответствующую лицензию.

Смотри также файл oemlogo.bmp


 oemlogo.bmp

oemlogo.bmp

Местонахождение

Windows\system32

Описание

Чтобы добавить собственную картинку в апплет Система Панели управления, надо создать или модифицировать картинку, которая находится в файле oemlogo.bmp и поместить файл в системную папку Windows (как правило Windows\system32)

Файл oemlogo.bmp создается в любом графическом редакторе (напр. Paint) с размером 172 на 100 пикселов (русская версия Windows XP). Надо сказать, что размеры картинки в разных версиях Windows постоянно менялись. Как правило, слишком большая картинка просто обрезается. Также необходимо иметь в этой же папке файл oeminfo.ini, иначе картинка не будет выводиться вообще

Строго говоря, данный файл не присутствует на чистом инсталяционном диске Windows, но может входить в Windows, который предустановлен на компьютерах различных производителей, имеющих соответствующую лицензию.


 openfiles.exe

openfiles.exe

Местонахождение

Windows\system32

Описание

Open Files

Запрашивает или отображает открытые файлы. Также запрашивает, отображает или разъединяет файлы, открытые сетевыми пользователями.

Синтаксис

openfiles.exe /query [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Описание параметров есть в справке Windows


 pathping.exe

pathping.exe

Местонахождение

Windows\system32

Описание

TCP/IP PathPing Command

Утилита командной строки pathping.exe в течение некоторого периода времени отправляет многочисленные сообщения с эхо-запросом каждому маршрутизатору, находящемуся между исходным пунктом и пунктом назначения, а затем на основании пакетов, полученных от каждого из них, вычисляет результаты. Поскольку pathping показывает коэффициент потери пакетов для каждого маршрутизатора или связи, можно определить маршрутизаторы или субсети, имеющие проблемы с сетью. Команда Pathping выполняет эквивалентное команде tracert действие, идентифицируя маршрутизаторы, находящиеся на пути. Затем она периодически в течение заданного времени обменивается пакетами со всеми маршрутизаторами и на основании числа пакетов, полученных от каждого из них, обрабатывает статистику. Запущенная без параметров, команда pathping выводит справку.

Описание программы и ее подкоманд есть в справке Windows.

Для отображения справки о подкомандах утилиты используйте команду pathping без параметров в командной строке

pathping

Синтаксис

pathping [-n] [-h максимальное_число_переходов] [-g список_узлов] [-p период] [-q число_запросов [-w интервал] [-T] [-R] [имя_конечного_компьютера]

Параметры

-n
Предотвращает попытки команды pathping сопоставить IP-адреса промежуточных маршутизаторов с их именами. Это позволяет ускорить вывод результатов команды pathping.
-h максимальное_число_переходов
Задает максимальное количество переходов на пути при поиске конечного пункта назначения. Значение по умолчанию равно 30.
-g список_узлов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в IP-заголовке с набором промежуточных мест назначения, указанным в списке_компьютеров. При свободной маршрутизации последовательные промежуточные места назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке равно 9. Список_адресов представляет собой набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-p период
Задает время ожидания между последовательными проверками связи (в миллисекундах). Значение по умолчанию равно 250 миллисекунд.
-q число_запросов
Задает количество сообщений с эхо-запросом, отправленных каждому маршрутизатору пути. По умолчанию - 100.
-w интервал
Задает время ожидания каждого отклика (в миллисекундах). Значение по умолчанию равно 3000 миллисекунд.
-T
Присоединяет тег приоритета уровня 2 (например 802.1p) к сообщениям с эхо-запросом, отправляемым каждому сетевому устройству на маршруте. Это помогает обнаружить сетевые устройства, для которых не настроен приоритет уровня 2. Он предназначен для проверки соединений, использующих спецификации QoS.
-R
Проверяет, все ли сетевые устройства вдоль маршрута поддерживают протокол RSVP (Resource Reservation Setup Protocol, протокол настройки резервирования ресурсов), который позволяет главному компьютеру резервировать определенную часть пропускной способности для потока данных. Этот параметр предназначен для проверки соединений, использующих спецификации QoS.
имя_конечного_компьютера
Задает пунтк назначения, идентифицированный IP-адресом или именем узла.
/?
Отображает справку в командной строке.

Примечания

Параметры команды Pathping вводятся с учетом регистра.

Во избежание перегрузки сети пакеты должны передаваться через довольно большие интервалы времени.

Чтобы минимизировать эффект потери пакетов, не нужно слишком часто выполнять проверку связи.

После запуска pathping сначала выводится путь. Это тот же путь, который выводится командой tracert. Далее в течение 90 секунд команда выдает сообщение о том, что она занята (это время варьируется в зависимости от числа переходов).В течение этого времени происходит сбор сведений со всех маршрутизаторов, перечисленных выше, и со всех соединений между ними. По завершении этого периода выводятся результаты проверки.


 perfmon.msc

perfmon.msc

Местонахождение

Windows\system32

Производительность (Performance Monitor)

Огромное количество счетчиков производительности компьютера (в т.ч. компьютера в сети) Загруженность процессора, памяти, кэша, логических дисков. Большое количество настроек и возможностей. Можно, например, узнать активность жесткого диска, его загруженность или отследить сколько байт занимает отдельно взятая программа в файле подкачки и т.д.


 ping.exe

ping.exe

Местонахождение

Windows\system32

Описание

TCP/IP Ping Command

Утилита командной строки Ping проверяет соединение на уровне протокола IP с другим компьютером, поддерживающим TCP/IP, с помощью отправки сообщений с эхо-запросом по протоколу ICMP . После каждой передачи выводится соответствующее сообщение с эхо-ответом. Ping - это основная TCP/IP-команда, используемая для устранения неполадки в соединении, проверки возможности доступа и разрешения имен. Команда ping, запущенная без параметров, выводит справку.

Синтаксис

ping [-t] [-a] [-n счетчик] [-l размер] [-f] [-i TTL] [-v тип] [-r счетчик] [-s счетчик] [{-j список_узлов | -k список_узлов}] [-w интервал] [имя_конечного_компьютера]

Описание параметров есть в справке Windows

Команда Ping лежит в основе диагностики сетей TCP/IP. Например, чтобы быстро получить значения параметров конфигурации TCP/IP на своем компьютере, следует набрать:

C:\>ping 127.0.0.1


 progman.exe

progman.exe

Местонахождение

Windows\system32

Описание

Program Manager (Диспетчер программ)

Из Windows 3.1 нам достался такой замечательный продукт, как PROGMAN.EXE. Он представляет из себя панель, которая с успехом может заменить Рабочий Стол, поскольку позволяет завести внутри себя неограниченное количество Групп, каждая из которых может содержать произвольное количество ярлыков (команды "Создать группу" и "Создать элемент" соответственно). Ярлык PROGMAN.EXE имеет смысл или помещать в стартовую папку с параметром "Свёрнутое в значок" (Windows 95, NT), или выводить на панель Quick Launch.
В результате можно существенно разгрузить Рабочий Стол, оставив на нём только необходимое. Остальные рабочие ярлыки можно разместить по группам Прогмана. В результате получится что-то вроде свёртываемого Рабочего Стола с рядом Рабочих Подстолов внутри!
P.S. К сожалению, PROGMAN.EXE обладает одним "родимым пятном" Windows 3.1: он не понимает длинных имён файлов, которые надо преобразовывать в короткие. Однако это неудобство не сильно умаляет его достоинства.


 reg.exe

reg.exe

Местонахождение

Windows\system32

Описание

Утилита редактирования системного реестра из командной строки

Данная утилита позволяет просматривать, добавлять, удалять различные данные из реестра. Дополнительную информацию можно получить, запустив в командной строке

reg /?

Примеры

Для получения номера версии Internet Explorer из реестра введите в командной строке:

reg query "HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer" /v Version


 regsvr32.exe

regsvr32.exe

Местонахождение

Windows\system32

Описание

Сервер регистрации, (C) Microsoft - Microsoft(C) Register Server

Данная команда регистрирует в реестре файлы .dll как компоненты команды. Данная утилита весьма активно используется программистами для регистрации различных собственных компонентов

Синтаксис

regsvr32 [/u] [/s] [/n] [/i[:cmdline]] имя_dll

Параметры

/u
Отменяет регистрацию сервера
/s
Задает запуск regsvr32 без вывода сообщений на экран.
/n
Указывает не вызывать DllRegisterServer. Этот параметр можно использовать с параметром /i.
/i:cmdline
Вызывает DllInstall с помощью дополнительной передачи [cmdline]. При использовании с параметром /u вызывает удаление dll.
dllname
Задает имя файла dll для последующей регистрации.
/?
Вывод справки в командной строке.

Примеры

Для регистрации файла .dll для схемы Active Directory введите:

regsvr32 schmmgmt.dll

Советы


Server 2003 Resource Kit Tools

Microsoft Windows Server 2003 Resource Kit Tools

Пакет Microsoft Windows Server 2003 Resource Kit Tools представляет собой набор инструментов, облегчающих выполнение большинства задач, связанных с администрированием, таких, как устранение неисправностей в работе операционной системы, управление службой Active Directory, настройка параметров сети и систем безопасности, а также автоматизация процесса разработки приложений.

Системные требования:
30 Мбайт свободного места на жестком диске.
Операционная система:
Windows XP с пакетом исправлений SP1.
Windows Server 2003.

Инструкция по установке:
Если у вас установлена бета-версия Resouce Kit Tools, необходимо удалить ее перед инсталляцией.
Щелкните на ссылке Download для начала загрузки. Выполните одно из перечисленных ниже действий:
Для того чтобы немедленно начать установку, запустите или откройте программу из ее текущего местоположения.

Для того чтобы скопировать установочные файлы на компьютер для последующей инсталляции, выберите опцию «Сохранить» или «Сохранить программу на диске».
Для установки инструментария Resource Kit tools, запустите файл rktools.exe. После подтверждения лицензионного соглашения (EULA), все необходимые файлы будут установлены в папку %Program Files%\Windows Resource Kits\Tools.
Перед началом работы с инструментами Resource Kit tools, ознакомьтесь с информацией, rjnjhfz содержится в файле readme.htm, расположенном в папке %Program Files%\Windows Resource Kits\Tools folder.

Загрузить пакет (12 Mb) можно с сайта компании Microsoft

В состав пакета вошли следующие инструменты:

Acctinfo.dll Additional Account Information Properties Page
Acctinfo.dll - это динамически подключаемая библиотека, которая будучи установленной на компьютере, добавляет новую страницу свойств (Дополнительная информация об учетных записях) к диалоговому окну свойств пользовательского объекта в модуле Active Directory Users and Computers. На новой странице свойств отображается такая информация, как дата последней установки пользовательского пароля, дата окончания срока действия пароля, а также дата и время последнего входа в систему и выхода из нее. Такая информация обычно недоступна в модуле Active Directory Users and Computers, по одной из причин перечисленных ниже:
В некоторых случаях информация не хранится в Active Directory, а вычисляется при возникшей необходимости. Например, дата окончания срока действия пароля не сохраняется в Active Directory, вместо этого программа сохраняет дату последней установки пароля и данные о максимальном сроке действия пароля (допустим, что пароль необходимо менять каждые 60 дней). Обычно, для того, чтобы определить дату, когда пароль будет считаться недействительным, вам приходилось использовать сценарий для извлечения обоих значений и рассчитывать требуемую дату. Библиотека Acctinfo.dll выполнит все вычисления за вас.
Иногда данные сохраняются локально, а не в каталогах Active Directory. Например, дата и время последнего входа в сеть и выхода из сети хранятся на отдельных контроллерах домена и не дублируется в масштабах домена. Библиотека Acctinfo.dll позволяет получить данные о времени последнего входа в сеть и выхода из сети с указанного контроллера домена. Если аутентификация пользователя выполняется одним контроллером доменов, вы получите информацию о подключении к данному домену и отключении от него. В случае если аутентификация выполняется несколькими контроллерами доменов, вам потребуется установить Acctinfo.dll на всех серверах и проверить данные учетных записей на каждом из них.
Библиотека Acctinfo.dll изначально предназначалась для предоставления информации о пользовательских паролях, состоянии учетных записей и идентификаторах для входа в систему. Однако, помимо перечисленных функций, библиотека снабжена механизмом для изменения паролей и снятия блокировки с учетных записей пользователя.
Adlb.exe: Active Directory Load Balancing Tool
Active Directory Load Balancing (ADLB) представляет собой инструмент с интерфейсом командной строки помогающий распределять существующие объекты соединения между серверами-мостами Active Directory и позволяющий составлять график, в соответствии с которым серверы-мосты будут выполнять репликацию. Если нагрузка не сбалансирована, возможно снижение производительности центрального процессора и ресурсов памяти контроллеров доменов, кроме того может возникнуть задержка в процессе репликации данных между доменами.
В процессе репликации Active Directory используются объекты соединения для управления входящим и исходящим трафиком между серверами-мостами. Инструмент Active Directory Load Balancing Tool (ADLB) распределяет трафик репликации между доступными серверами-мостами, отображая процесс репликации с разных ракурсов в рамках одного сайта.
Admx.msi: ADM File Parser
Средство ADM File Parser (AdmX) представляет собой инструмент с интерфейсом командной строки, позволяющий администратору экспортировать настройки групповых политик в виде текстового файла, компоненты которого отделены знаком табуляции. После этого, администратор может использовать созданный текст для обнаружения изменений в настройках политик, возникающих при работе с разными операционными системами. Инструмент AdmX поддерживает только те политики, которые созданы на базе административных шаблонов.
Atmarp.exe: Windows ATM ARP Server Information Tool
Windows ATM ARP Server Information Tool (AtmArp) представляет собой инструмент с интерфейсом командной строки, который помогает администраторам сети и персоналу выявить неполадки, связанные с настройками протокола разрешения адресов ARP для сетей ATM и службы многоканальной трансляции адресов MARS. Сети ATM обеспечивают поддержку групп стандартных технологий, которые гарантируют высокоскоростное взаимодействие между различными носителями информации.
Windows ATM ARP Server Information Tool предоставляет информацию о драйвере Atmarps.sys, который представляет собой интегрированный сервер протоколов ARP, MARS и протокола многоканального вещания MCS (multicast server) для сетей IP/ATM. Указанная служба обеспечит эффективное взаимодействие между серверами в сетях IP/ATM.
Atmlane.exe: Windows ATM LAN Emulation Client Information
Windows ATM LAN Emulation Client Information (AtmLanE) - это инструмент с интерфейсом командной строки, помогающий администраторам выявить неполадки в настройках клиентского модуля эмуляции локальных сетей ATM Local Area Network Emulation, входящего в комплект поставки операционных систем Windows 2000, Windows XP Professional или Windows Server 2003. Сети ATM обеспечивают поддержку групп стандартных технологий, которые гарантируют высокоскоростное взаимодействие между различными носителями информации.
При установке адаптера ATM на компьютер под управлением Windows 2000, Windows XP Professional или Windows Server 2003, по умолчанию инсталлируется и клиент эмулятора локальной сети (LANE). Если система подключена к коммутатору, поддерживающему службы LANE (уточните это у системного администратора или ознакомьтесь с документацией коммутатора ATM), установленный клиент способен взаимодействовать с другими клиентами в пределах эмулированной сети LAN.
Autoexnt.exe: AutoExNT Service
AutoExNT Service (AutoExNT) - это служба, которая позволит вам запускать командный файл Autoexnt.bat при загрузке системы, без подключения к компьютеру, на котором этот файл должен выполняться.
Служба AutoExNT Service позволяет администраторам настраивать параметры компьютера, под управлением операционной системы Windows, для запуска определенного командного файла при первой загрузке. Пользователю или администратору не требуется находиться в сети в момент запуска командного файла.
Cdburn.exe : ISO CD-ROM Burner
ISO CD-ROM Burner (CDBurn) - инструмент с интерфейсом командной строки, который позволяет пользователям записывать (прожигать) образы данных, расположенных на жестком диске, на компакт-диск с возможностью однократной записи (CD-R) и перезаписываемый компакт-диск (CD-RW). Образы могут содержать любую информацию, в том числе и необработанные данные. Инструмент также используется для удаления информации с дисков CD-RW.
Checkrepl.vbs: Check Replication
Средство Check Replication (CheckRepl) представляет собой инструмент с интерфейсом командной строки для мониторинга процесса репликации и просмотра топологии репликации для указанного контроллера доменов.
Chklnks.exe:
Link Check Wizard. Link Check Wizard (ChkLnks) - инструмент с графическим интерфейсом, позволяющий проверить все ссылки (ярлыки) на компьютере и определить их актуальность. В том случае, если Link Check Wizard не обнаруживает документа или приложения, на который указывает ссылка, он помечает ссылку как неработающую и предлагает удалить ее.
Chknic.exe: Network Interface Card Compliance Tool for Network Load Balancing
Check NIC (ChkNIC) - это инструмент с интерфейсом командной строки, который проверяет сетевые адаптеры на совместимость с системой распределения сетевой нагрузки Network Load Balancing (NLB).
Cleanspl.exe: Spooler Cleaner
Spooler Cleaner (CleanSpl) - инструмент с графическим интерфейсом, позволяющее восстановить первоначальное состояние очереди печати. Инструмент удаляет все задания принтера, данные о принтерах, драйверах и файлы очереди печати на указанном локальном или удаленном сервере.
Clearmem.exe: Clear Memory
Clear Memory (ClearMem) представляет собой инструмент с интерфейсом командной строки, который определит объем физической памяти компьютера, выделит достаточный объем данных для ее заполнения и обеспечит максимально быстрое обращение к информации. Утилита ClearMem также предоставляет доступ к файлам для очистки кэш-памяти, что позволяет занять минимум ресурсов памяти для работы других приложений. После этого инструмент Clear Memory освобождает распределенную память для возобновления нормальной работы системы.
В том случае, если ClearMem запускается дважды, большинство приложений начинают испытывать нехватку памяти. Для того, чтобы воспроизвести реальную нагрузку, необходимо запустить ClearMem несколько раз, поскольку система не пытается немедленно привести в рабочее состояние все доступные страницы физической памяти, а выполняет эту работу постепенно. При запуске ClearMem работа системы не некоторое время замедлится, поскольку выполняемое задание обладает более высоким приоритетом.
Clusdiag.msi: Cluster Diagnostics and Verification Tool
Инструмент Cluster Diagnostics and Verification (ClusDiag) предоставляет администраторам интерфейс для диагностики кластера, а также интерфейс к журналу регистрации, который помогает привести кластер в работоспособное состояние после сбоя. На основе информации, собранной в процессе тестирования, ClusDiag генерирует различные отчеты о работе кластера.
Clusfileport.dll: Cluster Print File Port
Инструмент Cluster Print File Port (ClusFilePort) расширяет возможности серверов кластерной печати. ClusFilePort позволяет принтерам в составе кластера сохранять данные в файл или переадресовывать задания принтера. Для этого утилита ClusFilePort добавляет тип Cluster File Ports в список доступных портов.
Clusterrecovery.exe: Server Cluster Recovery Utility
Server Cluster (MSCS) Recovery Utility (ClusterRecovery) - инструмент с графическим интерфейсом, предназначенный для сбора и хранения информации о кластере, которая может быть использована для восстановлении кластера после сбоя общей шины.
Cmdhere.inf: Command Here
Command Here (CmdHere) - это расширение оболочки, которое добавляет пункт CMD Prompt Here в контекстное меню, отображаемое при щелчке правой кнопкой мыши на панели «Папки» (расположенной слева) в Проводнике Windows. Выбор опции Command Here открывает новый сеанс работы с командной строкой, в котором указывается путь к выбранному объекту.
Cmgetcer.dll: Connection Manager Certificate Deployment Tool
Инструмент Connection Manager Certificate Deployment (CMGetCer) позволяет удаленным пользователям, которым необходим защищенный доступ к сети VPN для получения сертификата. Выдача сертификата, установленного на клиентском компьютере, осуществляется в несколько этапов. CMGetCer автоматизирует процесс регистрации сертификата и загружает его на клиентский компьютер.
Compress.exe: Средства сжатия файлов
Compress - инструмент, с интерфейсом командной строки, который используется для создания сжатых копий одного или нескольких файлов. Для восстановления оригинального состояния файлов используется утилита Expand.exe.
Confdisk.exe: Disk Configuration
Disk Configuration (ConfDisk) - это инструмент с интерфейсом командной строки, предназначенный для восстановления отказавших дисков кластера. ConfDisk использует механизм автоматического восстановления системы (ASR) для создания файла, в котором сохраняются данные о настройках локального кластера. В будущем этот файл может быть использован для восстановления кластера, в случае если сигнатура диска окажется неверной или резервная копия ASR будет недоступна.
Consume.exe: Memory Consumers Tool
Memory Consumers Tool (Consume) представляет собой инструмент с интерфейсом командной строки, используется в сочетании с тестами функциональности и испытаниями в предельном режиме, что позволяет убедиться в работоспособности приложения в условиях нехватки ресурсов (утилита Consume способна моделировать такие условия). Средство Memory Consumers Tool способно имитировать расход таких ресурсов, как физическая память, виртуальная память, дисковое пространство, процессорное время и размер пула ядра.
Creatfil.exe: Create File
Create File (CreatFil) - инструмент с интерфейсом командной строки, позволяющий создавать пустые файлы заданного размера, заполненные пробелами. Такое средство может оказаться полезным при тестировании поведения инструментов, приложений и программ настройки в условиях дефицита свободного места на жестком диске.
Csccmd.exe: Client-Side Caching Command-Line Options
Client Side Caching Command Line Options (CSCcmd) является инструментом с интерфейсом командной строки, позволяющим управлять копиями баз данных на локальном компьютере.
Custreasonedit.exe: Custom Reason Editor
Custom Reason Editor (CustReasonEdit) - инструмент, поддерживающий графический интерфейс и интерфейс командной строки, который позволяет пользователям добавлять, модифицировать и удалять значения custom reason используемые приложением Shutdown Event Tracker на компьютерах под управлением Windows Server 2003. Вы можете использовать командную строку для осуществления базовых операций, связанных с импортом и экспортом значений custom reason в системный реестр или применять графический интерфейс для их редактирования значений. CustReasonEdit предлагает набор образцов значений, которые помогут вам быстро освоить этот инструмент.
Delprof.exe: утилита для удаления профилей пользователей
Утилита User Profile Deletion (DelProf) - это инструмент с интерфейсом командной строки, который используется для удаления профилей пользователей на локальных и удаленных компьютерах. Профили пользователей могут вырастать в размерах и занимать значительное место на диске (больше одного мегабайта каждый), особенно в тех случаях, когда несколько пользователей работают на одном компьютере. Средство DelProf позволяет администраторам освободить дисковое пространство за счет удаления ненужных профилей. Широкие возможности настройки позволяют использовать инструмент User Profile Deletion Utility Tool для удаления профиля пользователя в том случае, если пользователь не проявляет активности в течении указанного времени.
Dh.exe: Display Heap
Display Heap (DH) - утилита с интерфейсом командной строки, позволяющая отображать информацию о резервировании памяти для процессов, запускаемых пользователями или используемой доле памяти, выделенной ядру. Вы также сможете блокировать кучи, тэги, стеки и объекты. DH позволяет идентифицировать процесс, информацию о котором необходимо отобразить, а также определить какую именно информацию нужно вывести на экран монитора. После этого инструмент записывает отформатированные выходные данные в текстовый файл.
Одна из самых полезных функций DH - это отображение списка потенциальных ошибок и неполадок в механизмах распределения, которые влекут за собой чрезмерный расход ресурсов памяти. Для символьной идентификации источников вызова, системе необходима возможность захвата обратной трассировки стека в процессе выполнения программы. Эта функциональная возможность поддерживается только платформами на базе процессора Intel Itanium.
Используйте утилиту DH для освобождения ресурсов памяти, выделенных для работы тестируемой программы. Запустите программу и запишите данные, выводимые DH в отдельный файл (например, dh1.dmp). Теперь дайте приложению поработать какое-то время и остановите его в состоянии, которое будет идентичным первой остановке. Снова используйте инструмент DH и запишите выводимые данные в другой файл (dh2.dmp).
Diskraid.exe: RAID Configuration Tool
RAID Configuration (DiskRaid) представляет собой утилиту с интерфейсом командной строки, предназначенную для настройки и управления избыточными массивами в независимых дисковых подсистемах хранения (RAID).
Diskuse.exe: User Disk Usage Tool
User Disk Usage Tool (DiskUse) - это инструмент с интерфейсом командной строки, предназначенный для сканирования отдельных каталогов, деревьев каталогов или целых дисков, а также для составления отчетов об объеме дискового пространства, используемом каждым из пользователей. Выводимая информация отображается в командном окне или сохраняется в виде таблицы или текстового файла. Кроме того, DiskUse может сформировать список всех файлов, принадлежащих пользователю или группе. К файлам в списке можно применять различные способы фильтрации.
Dnsdiag.exe: DNS Resolver Tool
DNS Resolver Tool (DNSDiag) - это инструмент с интерфейсом командной строки, позволяющий решать проблемы в процессе получения электронной почты. Большинство указанных проблем связано с неправильной работой службы имен доменов (DNS). DNSDiag моделирует процесс передачи кода по протоколу SMTP и отображает диагностические сообщения, которые позволяют следить за устранением ошибок в работе DNS. DNSDiag запускается на тех компьютерах, на которых служба DNS работает с ошибками.
Dumpfsmos.cmd: Dump FSMO Roles
Dump FSMO Roles (DumpFSMOs) - утилита с интерфейсом командной строки, отображающая роли мастеров операций (также называемых настраиваемыми мастерами единичных операций или FSMO) в доменах и лесах доменов указанного сервера. С помощью Dump FSMO Roles вы сможете определять имена контроллеров доменов, которые играют роли мастеров операций.
Всего насчитывается пять ролей мастеров операций. Две из них существуют на уровне леса доменов, это означает, что только один сервер может выполнять эту функцию для всего леса. Эти роли называются: мастер схемы и мастер именования доменов. Оставшиеся три роли существуют на уровне домена, что подразумевает наличие одного сервера для выполнения функций мастера операций на уровне всех доменов в составе леса. Эти роли называются: мастер относительных идентификаторов (RID), эмулятор первичного контроллера доменов и мастер инфраструктуры.
Dvdburn.exe: ISO DVD Burner Tool
ISO DVD Burner Tool (DVDBurn) - это инструмент с интерфейсом командной строки, позволяющий пользователям переписывать (прожигать) образы данных в формате DVD с жесткого диска компьютера на цифровые видеодиски (DVD). Для создания образа данных может использоваться любая программа, позволяющая создавать файлы DVD. Инструмент может также использоваться для удаления данных с DVD-диска.
Empty.exe: Free Working Set Tool
Free Working Set Tool (Empty) представляет собой инструмент с интерфейсом командной строки, освобождающий страницы физической памяти, используемые указанным процессом или заданием, позволяя задействовать их в других процессах.
Eventcombmt.exe: средство проверки процесса репликации
Event Comb (EventCombMT) - инструмент с графическим интерфейсом, позволяющий выполнять поиск журналов событий на различных компьютерах и серверах и осуществлять сбор идентификаторов EventID, соответствующих указанным критериям.
Fcopy.exe: File Copy Utility for Message Queuing
File Copy Utility for Message Queuing (FCopy) представляет собой консольную утилиту, предназначенную для сжатия файлов и папок для их последующего копирования в пределах сетей LAN и WAN. Благодаря использованию технологии Message Queuing (MSMQ), средство FCopy не прерывает процесс копирования даже в случае возникновения проблем в работе сети. Расширенные функциональные возможности FCopy позволяют выполнять копирование файлов лишь при наличии внесенных изменений.
FCopy разбивает файлы на 64 или 32-килобитные фрагменты, выполняет их сжатие и отправляет в виде сообщения Message Queuing (в режиме срочной пересылки). Вам не нужно перезапускать программу FCopy при возникновении сбоя в работе сети, технология Message Queuing обеспечит отправку сообщения в любом случае.
Инструмент FCopy использует быстродействующие алгоритмы сжатия данных и способно работать на любых компьютерах. Однако, наиболее полно возможности приложения реализуются при наличии низкоскоростных линий. При работе со стандартными адаптерами Ethernet, изменения в скорости копирования практически незаметны, за исключением случаев использования компьютеров с мощным процессором. Для тестирования FCopy использовались файлы размером более 5 Гбайт, но теоретически вы сможете копировать и более крупные файлы.
Frsflags.vbs
File Replication Service Flags (FrsFlags) - инструмент с интерфейсом командной строки, позволяющий включать и выключать функцию Install Override при работе со службой репликации файлов (FRS). Инструмент позволяет устанавливать и удалять атрибут FrsFlags, присущий копиям объектов Active Directory.
Getcm.exe: Connection Manager Profile Update
Get Connection Manager (GetCM) - это инструмент с интерфейсом командной строки, помогающий загружать новые профили Менеджера Подключений из Интернета или совместно используемых каталогов локальной системы. GetCM используется в сочетании с инструментами администратора Connection Manager Administration Kit (CMAK).
Gpmonitor.exe: Мониторинг групповых политик
Group Policy Monitor (GPMon) создает отчеты об обновлении настроек политик и позволяет администратору ознакомиться с этими отчетами. После чего администраторы могут проверить устойчивость объектов групповых политик (GPO) и выполнить мониторинг процесса репликации политик.
Gpotool.exe: Средство для работы с объектами групповых политик
Group Policy Verification Tool (GPOTool) представляет собой инструмент с интерфейсом командной строки, позволяющий администраторам проверить устойчивость объектов групповых политик и выполнить мониторинг процесса репликации политик. GPOTool позволяет просматривать объекты GPO и следить за их совместимостью в пределах и за пределами домена. Инструмент также отображает информацию, связанную с объектами GPO, включая свойства, к которым нельзя обратиться из редактора Group Policy Object Editor (например, номер версии и расширение глобально уникального идентификатора (GUID)).
Hlscan.exe: Hard Link Display
Hard Link Display (HLScan) - это консольная утилита отображающая жесткие ссылки на разделы NTFS или на конкретные файлы и папки в разделе. Жесткие ссылки представляют собой альтернативные логические имена физических файлов. Средство HLScan отображает список всех файлов, обладающих несколькими именами c указанием идентификатора файла в системе NTFS, общего количества имен данного файла, а также перечисляет все имена данного файла и указывает пути к нему.
Используя HLScan, администраторы могут обеспечить томам данных надежную защиту, благодаря возможности отображения всех жестких ссылок, которые были созданы для подтвержденных и неподтвержденных файлов.
Ifilttst.exe: IFilter Test Suite
IFilter Test Suite (IFilttst) - это инструмент с интерфейсом командной строки, помогающий обеспечить соответствие различных реализаций технологии IFilter c единой спецификацией. Совместимость со спецификацией IFilter позволяет создавать фильтры документов, которые используются службой индексации в продуктах компании Microsoft. The IFilter Test может запускаться на локальных компьютерах.
Ifilttst позволяет провести следующие тесты:
Тест на достоверность. Проверит, что фильтр разбивает документ на текстовые фрагменты, которые могут использоваться службой индексирования Indexing Service.
Тест на согласованность. Проверит, что документ разбивается на одинаковые фрагменты при каждом использовании фильтра.
Тест на обработку неверного ввода. Проверит способность фильтра корректно обрабатывать возникающие ошибки.
Ifmember.exe: User Membership Tool
User Membership (IfMember) - это консольная утилита, которая проверит является ли указанный пользователь членом конкретной группы. Данное средство чаще всего используется в сценариях Windows, обеспечивающих вход в систему, и в других командных файлах.
Инструмент IfMember использует собственные идентификаторы процессов для подтверждения членства в группе, в отличие от других средств, которые при каждом запуске отправляют запрос к соответствующему контроллеру домена. Хотя данный метод обеспечивает значительный рост производительности, он также означает, что IfMember проверяет группы на уровне локальных компьютеров, доменов и доверенных доменов и предоставляет отчет о членстве в группе на тот момент, когда был получен соответствующий идентификатор.
Inetesc.adm: Internet Explorer Enhanced Security Configuration
Internet Explorer Enhanced Security Configuration (InetESC) - это шаблон групповой политики, позволяющий более эффективно настроить систему безопасности Microsoft Internet Explorer.
Iniman.exe: Initialization Files Manipulation Tool
Initialization Files Manipulation (IniMan) - это инструмент с интерфейсом командной строки, который позволяет добавлять, удалять, вносить изменения или запрашивать разделы и ключи файла .ini. Примерами файлов .ini являются файлы с вопросами, используемые для установки приложений, файлы инициализации программы, и файлы с расширением .inf. IniMan также позволит вам создавать собственные файлы ответов, содержащие выбранные вами значения.
Instcm.exe: Install Connection Manager Profile
Install Connection Manager (InstCM) - средство с интерфейсом командной строки, предназначенное для установки профиля Connection Manager, который вы могли загрузить, используя утилиту GetCM. InstCM используется в сочетании с инструментариемConnection Manager Administration Kit (CMAK).Instsrv.exe: Service Installer
Service Installer (InstSrv) представляет собой консольную утилиту для инсталляции и деинсталляции исполняемых служб и присвоения им различных имен.
Intfiltr.exe: Interrupt Affinity Tool
Interrupt Affinity Filter (IntFiltr) - это инструмент с графическим интерфейсом, позволяющий изменять родственность процессора для обработки аппаратного прерывания. Используйте утилиту IntFiltr для указания типа обработки сигналов аппаратного прерывания для конкретных процессоров. Данная утилита способна существенно повысить производительность многопроцессорных систем.
Kerbtray.exe: Kerberos Tray
Kerberos Tray (KerbTray) - это инструмент с графическим интерфейсом, отображающий информацию о билетах в системах использующих протокол аутентификации Kerberos версии 5, адаптированный для работы с продуктами Microsoft.
Вы можете просматривать и освобождать область кэш памяти, предназначенную для хранения билетов, используя пиктограмму KerbTray, расположенную в области уведомления вашего рабочего стола. Наведя указатель мыши на пиктограмму вы увидите время, оставшееся до истечения срока действия билета на сеанс работы (TGT). Внешний вид пиктограммы изменится, когда до обновления билета локальным сервером выдачи сертификатов (LSA) останется один час.
Kernrate.exe: Kernel Profiling Tool
Kernel Profiling Tool (KernRate) - это консольная утилита, представляющая собой профайлер центрального процессора. Профайлер выполняет мониторинг производительности и отправляет пользователю отчет по результатам проверки. KernRate формирует отчеты о процессах ядра и пользовательских процессах, предоставляя информацию о работе центрального процессора. Используйте KernRate, чтобы определить какой из процессов вызвал перегрузку в работе центрального процессора.
KernRate разбивает адресное пространство памяти на управляемые участки. Мониторинг каждого фрагмента (участка) программы выполняется отдельно. При просмотре администратор сможет изменять масштаб предварительно отмеченного модуля.
Klist.exe: Kerberos List
Kerberos List (KList) - инструмент с интерфейсом командной строки для просмотра и удаления билетов Kerberos, используемых в текущем сеансе подключения к системе. Для того, чтобы просматривать билеты с помощью KList, вы должны запустить инструмент на компьютере, который является членом группы Kerberos.
При запуске с клиентского компьютера, утилита KList отображает:
Билет на сеанс работы (TGT) с центром распределения ключей Kerberos на платформе Windows.
Билет на сеанс работы (TGT) в системе Ksserver для UNIX.
Осторожно
Удаление билетов Kerberos может вызвать ошибки или прервать текущий сеанс работы в системе.
Krt.exe: Certification Authority Key Recovery
Key Recovery Tool (KRT) - средство с графическим интерфейсом, которое предоставляет агенту восстановления ключей (KRA) разрешения, необходимые для получения частных ключей от сервера выдачи сертификатов в среде Windows Server 2003.
Lbridge.cmd: L- Bridge
LBridge - это командный файл, который окажет поддержку в процессе репликации данных между контроллерами домена в смешанных средах. LBridge перемещает файлы из системных томов System Volume (sysvol), которые расположены на сервере Microsoft Windows Server 2003 в папку «Export» на сервере Windows NT версии 4.0.
Утилита LBridge выполняет функции моста между архитектурами репликации Windows NT 4.0 и Windows 2000 или Windows Server 2003. Предлагаемая утилита обеспечит перемещение файлов из каталогов Sysvol операционной системы Windows 2000 или Windows Server 2003 в папку «Export», используемую службой LMRepl (служба репликации каталогов в среде Windows NT 4.0) на серверах Windows NT 4.0. Преимущество такого подхода состоит в том, что он позволяет физически разделить два различных механизма репликации, что гарантирует отсутствие унаследованных служб контроллера доменов Windows 2000 или Windows Server 2003.
LBridge - это образец командного файла, который может быть адаптирован к вашим собственным нуждам. В качестве средства копирования можно использовать XCopy, RoboCopy или любую другую утилиту.
Linkd.exe
Инструмент LinkD представляет собой консольную утилиту для организации ссылок из папок файловой системы NTFS к различным объектам. Если исходная и конечная папки расположены на одном диске (в общих каталогах удаленного компьютера), LinkD сообщит, что процесс создания ссылки успешно завершен, но повторный синтаксический анализ невозможен. Средство LinkD добавит имя адресата непосредственно в именное пространство в указанном исходном каталоге. Впоследствии исходный каталог будет выполнять функции заменителя имени или узлового пункта, указывающего на целевой объект в дереве каталогов.
Исходный каталог:
Должен располагаться на диске, отформатированном с использованием NTFS 3.0.
Должен быть пустым.
Место назначения или адресат:
Должны соответствовать имени каталога, устройства или объекта, допустимому в среде Microsoft Windows.
Источник и адресат должны располагаться на диске, присоединенному к одному компьютеру. Утилита LinkD не работает на разных компьютерах. Если имя адресата не определяется каталогом или устройством, операция по открытию выполняется с ошибкой.
Linkspeed.exe: Link Speed
Link Speed (LinkSpeed) - инструмент с интерфейсом командной строки, отображающий скорость передачи данных между компьютерами локальной сети.
List.exe: List Text File Tool
List Text File (List) - консольная утилита, предназначенная для поиска и отображения одного или нескольких текстовых файлов. В отличие от других средств отображения текста, инструмент List не сохраняет файл в памяти при его открытии. Таким образом, пользователи могут редактировать текстовый файл в шестнадцатеричном формате.
Утилита List полезна при удаленном отображении текста или файлов журналов, а также при работе с серверами, администраторы которых заботятся о поддержании максимальной производительности системы.
Lockoutstatus.exe: Account Lockout Status
Утилита Account Lockout Status (LockoutStatus) сочетает интерфейс командной строки и графический интерфейс для отображения данных о блокировке конкретной учетной записи пользователя. LockoutStatus обеспечивает сбор информации из всех доступных контроллеров доменов в рамках домена, к которому принадлежит указанная учетная запись.
Logtime.exe
LogTime - это консольная утилита, которая регистрирует начало и окончание работы инструментов командной строки, указанных в командном файле. Данное средство полезно при определении времени выполнения программы и отслеживании пакетных заданий, таких как импорт адресов электронной почты.
LogTime создает файл журнала, под названием Logtime.log с отметками даты и времени, идущими за указанным параметром (в текстовой строке журнала). При запросе из командного файла, отмечается дата и время запуска утилиты LogTime (с заданными параметрами). Например, если утилита LogTime запускается до или после запуска программы, отмеченной в командном файле, в файле Logtime.log сохраняется информация о начале и окончании выполнения данной программы.
При каждом очередном использовании утилиты LogTime, новая информация добавляется в файл Logtime.log без перезаписи самого файла.
Lsreport.exe: Terminal Services Licensing Reporter
Terminal Services Licensing Reporter (LsReport) - инструмент с интерфейсом командной строки, предназначенный для генерирования отчетов по использованию лицензий, выдаваемых серверами Terminal Services. Утилита соединяется с сервером для получения информации о пакетах лицензий клиентского доступа, установленных на доступных серверах. По умолчанию средство LsReport сохраняет данные о лицензиях в файл Lsreport.txt, создаваемый в рабочей директории.
LsReport позволяет записывать информацию о лицензиях в журнал, элементы которого разделены знаком табуляции. Экспортируемые данные могут использоваться для того, чтобы следить за использованием лицензий и потреблением ресурсов в вашей организации.
Lsview.exe: Terminal Services License Server Viewer
Terminal Services License Server Viewer (LSView)- утилита с графическим интерфейсом, отображающая информацию обо всех доступных серверах Terminal Services в масштабах домена или сайта. Данное средство расширяет возможности мониторинга и регистрации состояния серверов лицензий.
LsView отображает следующую информацию:
Имена всех серверов лицензий в рамках отдельного домена или сайта. При этом учитываются сервера недавно добавленные в домен и сервера лицензий, принадлежащие сайту Active Directory в рамках домена.
Типы всех серверов лицензий в рамках домена. Существует два типа упомянутых серверов: сервер лицензий предприятия и сервер лицензий домена. Тип Workgroup License Server используется рабочими группами в масштабах домена. Умение определить тип сервера бывает необходимым при устранении неполадок.
Дату и время доступности каждого сервера лицензий. По умолчанию, утилита LsView проверяет доступность сервера каждые пять минут.
Mcast.exe: Multicast Packet Tool
Multicast Packet Tool (Mcast) - консольная утилита, которая используется для широковещательной рассылки пакетов или для прослушивания пакетов, отправленных на широковещательный адрес группы. Инструмент Mcast также применяется для тестирования широковещательной связи между компьютерами в составе локальной сети.
Memmonitor.exe: Memory Monitor
Memory Monitor (MemMonitor) - инструмент с интерфейсом командной строки, позволяющий следить за использованием ресурсов памяти в различных процессах и запускать отладчик при достижении указанных пороговых значений.
Memtriage.exe: Resource Leak Triage Tool
Resource Leak Triage Tool (MemTriage) представляет собой инструмент с использованием интерфейса командной строки, помогающий обнаруживать возможную утечку системных ресурсов. В специальном журнале MemTriage сохраняет информацию о выполняемых процессах или размерах пула ядра. После этого вы можете использовать MemTriage для анализа журнала и диагностики возможных проблем в работе системных ресурсов (включая память, идентификаторы, интерфейсы графических устройств (GDI), пользовательские ресурсы и ядро). Как только проблема идентифицирована, утилит MemTriage генерирует отчет и предлагает свои варианты дальнейших действий.
Mibcc.exe: SNMP MIB Compiler
SNMP MIB Compiler (MIBCC) - это консольная утилита, которая компилирует файлы протокола SNMP MIB. Используйте этот инструмент, когда вам понадобится программный интерфейс на базе протокола SNMP для работы с новой или обновленной информационной базой.
Moveuser.exe: Move Users
Move User (MoveUser) представляет собой инструмент с интерфейсом командной строки, предназначенный для изменения уровня безопасности профиля пользователя, для его использования с различными учетными записями. Применяйте утилиту MoveUser после перемещения пользователя в другой домен, что позволит сохранить профиль пользователя, связанный с оригинальной учетной записью.
Mscep.dll: Certificate Services Add-on for Simple Certificate Enrollment Protocol
MSCEP.dll - это динамически подключаемая библиотека (DLL), расширяющая возможности службы сертификации программного интерфейса Internet Service Application Program Interface (ISAPI). Это приложение позволит использовать протокол Microsoft Simple Certificate Enrollment Protocol (MSCEP) при работе с серверами выдачи сертификатов в среде Windows Server 2003, что гарантирует возможность передачи сертификатов по специальному протоколу Simple Certificate Enrollment Protocol (SCEP).
Nlsinfo.exe: Locale Information Tool
Locale Information Tool (NLSInfo) представляет собой инструмент с интерфейсом командной строки, отображающий информацию о настройках параметров компьютера с учетом местной специфики.
Now.exe: STDOUT Current Date and Time
STDOUT Current Date and Time (Now) - консольная утилита , которая считывает данные стандартного потока ввода (STDIN), после чего использует стандартный поток вывода (STDOUT) для отображения текущего времени и даты и введенной информации.
Ntimer.exe: Windows Program Timer
Windows Program Timer (NTimer) - это инструмент с интерфейсом командной строки, определяющий время работы программы. NTimer отображает истекшее время, время работы в пользовательском режиме и время работы в привилегированном режиме. Точность указанного времени обусловлена только разрешающей способностью таймера, которая составляет 10 миллисекунд на компьютерах с архитектурой x86.
Ntrights.exe
Консольная утилита NTRights позволяет управлять процессом предоставления прав пользователям или группам пользователей на локальных или удаленных компьютерах. Вы также сможете добавлять в журнал событий записи об изменении статуса.
Наиболее полно преимущества утилиты NTRights реализуются при необходимости неконтролируемой или автоматической инсталляции, во время которой вы хотели бы изменить разрешения, данные по умолчанию. Инструмент также полезен в тех ситуациях, когда вы хотите наделить пользователя правом доступа к существующему приложению (или лишить его такого права), но не имеете возможности подключиться ко всем компьютерам.
Oh.exe: Open Handles
Open Handles (OH) - инструмент с интерфейсом командной строки, который отображает список всех открытых окон приложений. Утилита OH также используется для отображения информации, касающейся конкретного процесса, типа объектов или имени объектов. Данное средство помогает обнаружить процесс, файлы которого были открыты в то время, когда были обнаружены нарушения процедуры совместного использования.
Oleview.exe: OLE/COM Object Viewer
OLE/COM Object Viewer (OLEView) - утилита с графическим интерфейсом, позволяющая управлять всеми классами COM, установленными на вашем компьютере.
Pathman.exe: Path Manager
Path Manager (PathMan) представляет собой консольную утилиту, которая позволяет добавлять или удалять системные компоненты и установленные пользователем пути. PathMan позволяет изменять любое количество путей в рамках одного вызова и предоставляет средства для обнаружения и обработки ошибок в указании путей (таких, как повторяющиеся записи, пропущенные записи, а также лишние и недостающие точки с запятой).
Permcopy.exe: Share Permissions Copy
Share Permissions Copy (PermCopy) - инструмент с интерфейсом командной строки, копирующий разрешения на работу с общими ресурсами (полный контроль, только чтение, внесение изменений) от одного ресурса к другому.
Важно
Копирование разрешений в общие папки администратора, размещенные на компьютерах с архитектурой x86 повлечет за собой прекращение работы утилиты Services.exe.
Perms.exe: User File Permissions Tool
User File Permissions (Perms) - инструмент с интерфейсом командной строки, отображающий разрешения на доступ пользователей к файлам и папкам в разделах файловой системы NTFS. Утилита Perms запрашивает разрешение, соответствующее указанному элементу контроля доступа (ACE) и отображает только те разрешения, которые выданы данным элементом.
Pfmon.exe: Page Fault Monitor
Консольная утилита Page Fault Monitor (PFMon) позволяет разработчикам и системным администраторам выполнять мониторинг сбоев при открытии страниц, которые происходят в процессе выполнения приложения. Эффективность PFMon особенно заметна при отслеживании ошибок программной страницы и ошибок страницы диска, поскольку указанный инструмент позволяет обнаружить источник ошибки.
Примечания:
Утилиту PFMon необходимо запускать из командного окна.
Если вы закроете командное окно во время обработки процесса средствами PFMon, процесс завершится, не дав пользователю возможности сохранить изменения.
Pkiview.msc: PKI Health Tool
PKI Health Tool (PKIView) - это встроенный компонент MMC, отображающий состояние одного или нескольких уполномоченных серверов выдачи и проверки сертификатов Microsoft Windows Server 2003 Certification Authorities, которые дополняют инфраструктуру открытых ключей (PKI).
PKIView обращается к каждому серверу выдачи и проверки сертификатов в организации для получения информации о сертификатах CA и списках отзыва сертификатов (CRLs). Проверка полученных данных позволяет убедиться в их корректной работе. В случае если проверяемые сертификаты не работают, PKIView отобразит соответствующее сообщение или пометит информацию, как ошибочную.
PKIView отображает состояние серверов выдачи и проверки сертификатов Windows Server 2003 Certification Authorities установленных в лесах Active Directory. Используя эту утилиту, вы сможете обнаружить все компоненты инфраструктуры открытых ключей, включая подчиненные и корневые центры сертификации, связанные с корпоративным сервером выдачи сертификатов. Кроме того, инструмент обеспечивает возможность управления важными контейнерами PKI, такими как корневые центры сертификации и хранилища NTAuth, которые также содержатся в разделе настроек лесов Active Directory.
Pmon.exe: Process Resource Monitor Process Resource Monitor (PMon) представляет собой инструмент с интерфейсом командной строки, который отображает интенсивность использования ресурсов памяти и центрального процессора при выполнении различных процессов. Индикатор PMon отображается в командном окне. Информация обновляется каждые несколько секунд, при этом утилита не требует настройки.
Используйте PMon для оценки интенсивности использования страничной и неоткачиваемой памяти и обнаружения утечек памяти при работе в режиме ядра.
Printdriverinfo.exe: Drivers Source Drivers Source (PrintDriverInfo) - это консольная утилита для сбора информации о драйверах принтера. Первоначально утилита предназначалась для предоставления поддержки. Собранные данные включают информацию о формате и типе драйвера. Инструмент также способен присвоить драйвер определенному принтеру.
Prnadmin.dll: Printer Administration Objects
Printer Administration Objects (PrnAdmin) - инструмент на базе технологии COM, предоставляющий широкие возможности, неинтерактивного управления принтерами, драйверами и портами на локальных и удаленных компьютерах.
Используя PrnAdmin вы сможете:
Добавлять и удалять локальные и удаленные принтеры.
Добавлять и удалять подключения к принтерам.
Добавлять и удалять локальные и удаленные формы.
Добавлять и удалять локальные и удаленные стандартные порты TCP/IP (например, Line Printer Remote (LPR) или RAW).
Добавлять и удалять локальные и удаленные драйверы.
Отображать список принтеров, портов, драйверов и форм на локальном или удаленном компьютере.
Настраивать локальные и удаленные принтеры и управлять ими.
Утилита PrnAdmin состоит из нескольких объектов COM, размещенных в библиотеке Prnadmin.dll, выполняющей функции упаковщика для библиотеки Printui.dll. Вместе с инструментом вам будут предоставлены несколько образцов сценариев Microsoft Visual Basic.
Qgrep.exe
Qgrep представляет собой инструмент с интерфейсом командной строки, используемый для поиска определенной строки или фрагмента в пределах файла или списка файлов и отображения строк, отвечающих критериям поиска. Утилита QGrep может использоваться для обнаружения нужной информации в многочисленных файлах и подкаталогах.
Утилита Qgrep аналогична инструменту grep.exe. в операционной системе UNIX
Qtcp.exe: QoS Time Stamp
Утилита Qtcp предназначена для оценки качества работы сетевых служб. Qtcp пересылает ряд тестовых пакетов по локальной сети, после чего формирует отчет о задержках, вызванных каждым пакетом. Пакеты, не дошедшие до пункта назначения, помечаются как утерянные. Инструмент с одинаковой эффективностью используется на производстве и в сетях для проведения тестирования.
Queryad.vbs: Query Active Directory
Консольная утилита Query Active Directory (QueryAD) представляет собой сценарий на языке Visual Basic, предназначенный для отправки запросов в службу Active Directory.
Rassrvmon.exe: RAS Server Monitor
RAS Server Monitor (RASSrvMon) - это средство с графическим интерфейсом, которое обеспечит мониторинг деятельности сервера удаленного доступа (RAS), предоставляя более подробную информацию, чем стандартные инструменты Windows.
Rcontrolad.exe: Active Directory Remote Control Add-On
Active Directory Remote Control Add-On (RControlAD) - средство для подключения к рабочему столу удаленного компьютера с консоли Active Directory на платформах Windows 2003 Server или Windows XP Professional. Кроме того, вы сможете организовать подключение к терминальному серверу на базе Windows 2003 Server или Windows 2000 Server. RControlAD упрощает процесс удаленного администрирования серверов.
Regini.exe: Registry Change by Script
Registry Change by Script (RegIni) - инструмент с интерфейсом командной строки, позволяющий добавлять и модернизировать ключи и значения реестра путем указания соответствующего сценария.
Внимание
Не используйте редактор реестра для непосредственного редактирования, до тех пор пока это не останется единственным средством. Редактор реестра игнорирует требования к безопасности, предусмотренные инструментами администратора. Средства безопасности предотвратят возникновение конфликтов, снижение производительности и ошибки в работе системы. Прямое редактирование реестра может привести к непредсказуемым последствиям, от ошибок при запуске операционной системы до необходимости в ее повторной инсталляции. Для настройки и изменения параметров операционной системы Windows используйте программы контрольной панели или консоли управления Microsoft Management Console (MMC), когда это возможно.
Regview.exe Registry Viewer Tool
Registry Viewer Tool (RegView) - это консольная утилита, предназначенная для просмотра файлов регистрации групповых политик Registry.pol без записи в системный реестр.
Remapkey.exe: Remap Windows Keyboard Layout
Remap Windows Keyboard Layout (RemapKey) - инструмент с графическим интерфейсом, позволяющий изменять раскладку клавиатуры путем преобразования кодов опроса клавиатуры.
Robocopy.exe: Robust File Copy Utility
Этот инструмент с интерфейсом командной строки упрощает поддержку идентичных копий дерева каталогов, расположенных в разных местах (как на одном компьютере, так и в разных точках локальной сети). Утилита Robust File Copy (RoboCopy) предоставляет эффективную поддержку зеркальных отображений крупных деревьев каталогов на серверах локальной сети, разделенных медленными или ненадежными ссылками WAN.
По умолчанию RoboCopy игнорирует исходные атрибуты при выборе файла для копирования и копирует любые файлы, соответствующие указанному состоянию, независимо от их атрибутов.
RoboCopy отображает журнал файлов и папок в окне командной строки, предоставляя информацию об:
Обрабатываемых папках.
Копируемых файлах и причинах копирования.
Ошибках в работе сети.
Несовместимости между исходной и конечной структурами дерева каталогов.
Выводимые данные могут сохраняться в файл на диске. Перед закрытием утилита RoboCopy формирует в окне командной строки отчет обо всех операциях, выполненных в течение сеанса, или записывает информацию в файл на диске.
Примечание
RoboCopy не запускается на компьютерах под управлением Microsoft Windows 95 или Microsoft Windows NT версии 3.5x. В основе RoboCopy лежит стандарт Unicode, а операционная система Windows 95 не обеспечивает полной поддержки этого стандарта. Кроме того, RoboCopy использует программный интерфейс CopyFileEx() Win32 API, который поддерживается операционной системой Microsoft Windows 2000 и Microsoft Windows NT версии 4.0, но не работает в среде Windows NT 3.5x.
Rpccfg.exe: RPC Configuration Tool
RPC Configuration Tool (RpcCfg) - это консольная утилита для настройки службы вызова удаленной процедуры (RPC), позволяющей прослушивать указанные порты. Кроме того, инструмент отображает настройки портов и восстанавливает параметры, заданные по умолчанию.
Разработчики и администраторы могут использовать этот инструмент для настройки, перезапуска и проверки портов, используемых для вызова удаленной процедуры, вместо того, чтобы вносить изменения в системный реестр.
Rpcdump.exe
RPC Endpoint Diagnostic Utility (RCPDump) - это инструмент с интерфейсом командной строки, который запрашивает конечные точки удаленного вызова процедуры и формирует отчеты о состоянии служб RPC на уровне всей системы.
RPCDump отправляет в базу данных распределителя конечных точек запрос на получение списка всех зарегистрированных конечных точек. Если утилита запускается с ключом /i, инструмент проверит каждую конечную точку, чтобы определить прослушивается ли та служба, к которой относится данная точка. После сбора статистических данных, RPCDump отсортирует их и выведет на экран монитора.
Инструмент позволяет изолировать ошибки в работе сети с использованием служб вызова удаленной процедуры.
Rpcping.exe
Консольная утилита RPC Ping (RPCPing) помогает пользователям устранять ошибки в соединении между компьютерами с использованием службы вызова удаленной процедуры (RPC). Инструмент RPCPing напоминает утилиту Packet Internet Groper (PING) предназначенную для работы с соединениями по протоколу TCP/IP. Единственным отличием является то, что RPCPing тестирует соединения RPC, а не IP-подключения.
RPing: RPC Connectivity Verification Tool
Предлагаемая утилита позволяет убедиться в том, что службы удаленного вызова процедуры (RPC), отвечают на запросы со стороны RPC-клиентов.
Инструмент RPing состоит из двух компонентов: RPingS и RPingC. RPingS - это серверная часть программы, реагирующая на вызов функций Echo и Stats из интерфейса утилиты RPC Ping Tool (RpingC.exe), установленной на клиентском компьютере. Рабочую документацию вы найдете на странице пользовательского интерфейса RPing.
Rqc.exe: Remote Access Quarantine Client
Инструмент Remote Access Quarantine Client (RQC) расширяет возможности функции Network Access Quarantine Control в среде Windows Server 2003,, отказывая удаленным клиентам в полном доступе к локальной сети до тех пор, пока не будут выполнены предъявляемые требования.
Windows Resource Kit Tools состоит из двух компонентов (RQC и RQS) в составе средства управления Network Access Quarantine Control на платформе Windows Server 2003. Утилита RQS запускается на сервере удаленного доступа в качестве компонента listener и сообщает серверу, когда клиент может быть выведен из режима карантина. Компонент RQC устанавливается на клиентском компьютере и отвечает за отправку уведомлений компоненту listener в том случае, если удаленный клиент соответствует предъявленным требованиям.
Rqs.exe: Remote Access Quarantine Agent
Инструмент Remote Access Quarantine Agent (RQS) расширяет возможности функции Network Access Quarantine Control в среде Windows Server 2003, отказывая удаленным клиентам в полном доступе к локальной сети до тех пор, пока не будут выполнены предъявляемые требования.
Windows Resource Kit Tools состоит из двух компонентов (RQS и RQC) в составе средства управления Network Access Quarantine Control на платформе Windows Server 2003. Утилита RQS запускается на сервере удаленного доступа в качестве компонента listener и сообщает серверу, когда клиент может быть выведен из режима карантина. Компонент RQC устанавливается на клиентском компьютере и отвечает за отправку уведомлений компоненту listener в том случае, если удаленный клиент соответствует предъявленным требованиям.
Setprinter.exe: Spooler Configuration Tool
Spooler Configuration Tool (SetPrinter)- это консольная утилита, используемая для настройки параметров и состояния локальных и удаленных принтеров (утилита может использоваться с отдельными принтерами или со всеми принтерами на сервере).
Showacls.exe
Show ACLs (ShowACLs) представляет собой инструмент с интерфейсом командной строки, отображающее права доступа к файлам, папкам и деревьям. Утилита предусматривает использование масок, что позволяет учитывать только определенные списки контроля доступа (ACLs). ShowACLs работает только в разделах файловой системы NTFS.
ShowACLs также позволяет просматривать разрешения, выданные конкретному пользователю. Для этого ShowACLs пересчитывает локальные и глобальные группы к которым принадлежит пользователь и сравнивает пользовательские идентификаторы безопасности (SID) и идентификаторы группы с идентификаторами SID каждого элемента контроля доступа (ACE).
Showperf.exe: Performance Data Block Dump Utility
Performance Data Block Dump Utility (ShowPerf) - инструмент с графическим интерфейсом, который обеспечивает загрузку и запуск динамически-подключаемых библиотек (DLLs), отвечающих за работу счетчиков производительности на локальных и удаленных компьютерах. После этого ShowPerf извлекает данные из внешних буферов счетчиков производительности и выводит их на экран монитора.
Администраторы и разработчики счетчиков производительности могут использовать утилиту ShowPerf для идентификации счетчиков, которые система не в состоянии загрузить, а также счетчиков, отключенных по причине сбоя библиотек DLL во время испытания надежности системы. Кроме того, инструмент ShowPerf поможет обнаружить ошибки в данных, предоставляемых счетчиками производительности.
ShowPerf отображает следующие данные:
Объекты доступа к данным о производительности системы и активные экземпляры этих объектов (отключенные объекты не отображаются.).
Индекс объекта в реестре производительности (HKEY_PERFORMANCE_DATA).
Индивидуальные счетчики производительности для каждого объекта.
Индекс счетчика в реестре производительности (HKEY_PERFORMANCE_DATA)
Тип данных, добываемых каждым из счетчиков производительности.
Неформатированную информацию из блоков данных, добытую счетчиком производительности.
Showpriv.exe: Show Privilege
Show Privilege (ShowPriv) - средство с интерфейсом командной строки, предназначенное для отображения прав, предоставленных пользователям и группам. ShowPriv может запускаться на локальном компьютере или контроллере домена для отображения пользователей или групп, обладающих привилегированными правами на работу с доменом.
Sleep.exe: Batch File Wait
Консольная утилита Batch File Wait (Sleep) переводит компьютер в режим ожидания на указанный период времени.
Sonar.exe: FRS Status Viewer
FRS Status Viewer (Sonar) представляет собой инструмент с интерфейсом командной строки, позволяющий администраторам выполнять мониторинг ключевой статистической информации и состояния компонентов наборов для репликации данных используемых службой File replication service (FRS). Администраторы могут использовать Sonar для просмотра ключевых статистических данных наборов репликации, выполнять мониторинг уровней трафика, незавершенных заданий и свободного дискового пространства.
Splinfo.exe: Print Spooler Information
Print Spooler Information (SplInfo) - это консольная утилита, которая осуществляет сбор информации из очереди печати и выводит ее на экран монитора.
Srvany.exe: Applications as Services Utility
Утилита Applications as Services (SrvAny) позволяет запускать 32-разрядные или 16-разрядные приложения в виде служб. Хотя инструмент SrvAny работает только в операционной системе Windows Server 2003, он поддерживает 32-разрядные приложения для Windows Server 2003, Windows 2000 или Windows NT. Кроме того, вы сможете запускать 16-разрядные приложения Windows в виде служб, однако некоторые из этих приложений будут отключаться при выходе пользователя из системы.
Ниже перечислены основные преимущества запуска приложений в виде служб:
При выходе пользователя из системы, работа 32-разрядного приложения, запущенного в качестве службы, не прерывается. Другими словами, пользователю не нужно будет повторно запускать приложение при каждом входе в систему.
Приложения, запущенные в качестве служб, способны обрабатывать запросы без вмешательства пользователя. Поскольку приложения являются интерактивными, запросы продолжают обрабатываться даже в тех случаях, когда ни один из пользователей не подключен к серверу.
Приложения, запущенные в качестве служб, используют собственные учетные записи для входа в систему. Это означает, что приложение будет выполняться и обрабатывать запросы даже при отсутствии у пользователя прав на управление данным приложением.
Srvcheck.exe: Server Share Check
Server Share Check (SrvCheck) - это консольная утилита, отображающая список общих папок, которые не помечены, как «скрытые», а также перечисляет списки контроля доступа (ACL) для каждого общего ресурса.
Srvinfo.exe: Remote Server Information
Remote Server Information (SrvInfo) - инструмент с интерфейсом командной строки, который отображает информацию о сервере или рабочей станции, включая данные о свободном месте на диске, типах разделов и состоянии служб.
Srvmgr.exe: Server Manager
Инструмент с графическим интерфейсом Server Manager for Domains (SrvMgr) используется для управления доменами и компьютерами Microsoft Windows NT версии 4.0 или Microsoft Windows NT версии 3.51. Для управления доменами и компьютерами под управлением Windows 2000 и Windows Server 2003, вы можете воспользоваться службой каталогов Active Directory и другими средствами администрирования.
Ssdformat.exe: System State Data Formatter
System State Data Formatter (SSDFormat) представляет собой консольную утилиту для создания форматированной копии журнала данных о состоянии системы (SSD). SSDFormat.exe открывает файл журнала SSD, добавляет заголовок XSL для форматирования данных и сохраняет изменения в новом файле XML. Для открытия файла XML, созданного с помощью SSDFormat может использоваться любое средство просмотра с поддержкой XML (например, Internet Explorer). Утилита корректно отображает любые специальные символы и преобразует данные в табличный формат.
Subinacl.exe
SubInACL - инструмент с графическим интерфейсом, позволяющий администраторам добывать информацию, относящуюся к безопасности файлов, ключей реестра и служб. Собранная информация может пересылаться между пользователями, локальными или глобальными группами, а также между доменами.
Например, при перемещении пользователя из домена А в домен Б, администратор может заменить указать новое имя домена в файле с информацией, касающейся безопасности. Таким образом, из нового домена пользователь сможет обращаться к тем же самым ресурсам.
SubInACL позволяет администраторам выполнять следующие действия:
Отображать информацию, связанную с безопасностью файлов, ключей реестра или служб (включая данные о владельце, группе, списках контроля доступа (ACL), дискреционных списках ACL (DACL) и системных списках ACL (SACL).
Изменять владельца объекта.
Заменять данные по безопасности, относящиеся к одному идентификатору (включая учетные записи, группы, известные идентификаторы безопасности (SID)) на равноценные данные, относящиеся к другому идентификатору.
Осуществлять перенос информации, связанной с безопасностью объекта. Эта функция может оказаться полезной при реорганизации сетевых доменов и при возникновении необходимости в переносе соответствующей информации с одного домена на другой.
Tail.exe
Tail - это консольная утилита предназначенная для отображения указанного пользователем количества строк текстового файла (например, журнала) в окне консоли.
Tcmon.exe: Traffic Control Monitor
Утилита Traffic Control Monitor (TCMon) использует графический интерфейс для просмотра и управления потоками трафика на другом сетевом адаптере.
TCMon предоставляет следующие функциональные возможности:
Мониторинг приложений. Вы сможете выполнять мониторинг потоков трафика, создаваемого приложениями, которые используют перечисленные ниже программные интерфейсы и службы:
Программные интерфейсы GQoS API.
Программные интерфейсы Traffic Control API.
Службы IIS 6 (регулирование пропускной способности)
Управление фильтрами и потоками трафика. Вы сможете создавать пометки, расставлять приоритеты или ограничивать потоки трафика, путем создания фильтров и потоков.
Timeit.exe
Консольная утилита TimeIt записывает данные о времени, необходимом для выполнения конкретной команды.
Timezone.exe: Daylight Saving Time Update Utility
Daylight Saving Time Update (TimeZone) представляет собой инструмент с интерфейсом командной строки для управления процессом перевода часов на летнее время. В некоторых странах и регионах, дата перехода на летнее время изменяется год от года и не привязана к конкретному временному отрезку. TimeZone позволяет отрегулировать дату наступления и окончания периода летнего времени, при наступлении указанной даты настройки времени вашего компьютера будут автоматически обновлены.
Tsctst.exe: Terminal Server Client License Dump Tool
Terminal Server Client License Dump (TscTst) - это консольная утилита, которая удаляет информацию о лицензии, выданной клиенту Terminal Services. Эта лицензия является единственной, которую приобретает клиент при подключении к терминальному серверу.
Tsscalling.exe: Terminal Services Scalability Planning Tools
Terminal Services Scalability Planning Tools (TSSCalling) - это набор инструментов, которые помогут организациям спланировать загрузку производственных мощностей при работе со службами Microsoft Windows 2003 Terminal Services. Сотрудники организации смогут управлять рабочей нагрузкой на сервер, с легкостью определяя способен ли сервер справиться с возложенными на него рабочими задачами.
В состав пакета вошли следующие средства автоматизации:
Инструмент Robosrv.exe управляет сервером в процессе тестирования рабочей нагрузки. При совместном использовании утилиты RoboServer и RoboClient автоматизируют процесс взаимодействия между клиентом и сервером. Чаще всего RoboServer устанавливается на контролирующем компьютере и запускается до начала работы RoboClient. После того, как оба приложения запущены, RoboServer использует RoboClients для запуска сценариев, отвечающих за загрузку терминального сервера с интервалами, определенными оператором.
Инструмент Robocli.exe управляет клиентским компьютером в процессе тестирования рабочей нагрузки. При совместном использовании утилиты RoboServer и RoboClient автоматизируют процесс взаимодействия между клиентом и сервером. Приложение RoboClient устанавливается на клиентском компьютере и для начала работы требует запуска программы RoboServer. RoboClient получает от RoboServer команду на запуск сценариев, отвечающих за загрузку терминального сервера с интервалами, определенными оператором.
В состав пакета вошли следующие средства тестирования:
Инструмент Qidle.exe используется в автоматизированных средах для определения запущенных сценариев, которые выполняются с ошибкой и требуют вмешательства администратора. Для этого QIdle периодически проверяет сеансы подключения к терминальному серверу, которые бездействуют дольше предусмотренного периода времени. В случае обнаружения неактивного сеанса, QIdle уведомляет об этом администратора с помощью звукового сигнала.
Tbscript.exe представляет собой программу-интерпретатор, которая выполняет сценарии Visual Basic Scripting Edition и поддерживает специальные расширения для управления клиентами терминального сервера.
В состав пакета вошли следующие справочные файлы:
Файл TBScript.doc предоставляет подробную документацию по использованию сценариев Terminal Services.
Файл TSScalingSetup.doc предоставляет информацию по настройке масштабируемой тестовой среды. Ниже приведен список предлагаемых тем:
Аппаратные требования.
Настройка контроллера домена.
Настройка сервера Exchange.
Настройка терминального сервера.
Настройка клиентского компьютера.
Список необходимых файлов.
Файл TSScalingTesting.doc предоставляет исчерпывающее описание процесса тестирования. Ниже приведен список предлагаемых тем:
Операции по установке Windows Server 2003
Операции по установке Windows 2000
Настройка Windows 2000 после инсталляции.
Настройка Windows Server 2003 после инсталляции.
Операции по настройке и установке Office 2000
Операции по настройке и установке Office XP
Настройка счетчиков производительности.
Операции по удалению хранилища Exchange.
Выполнение сценариев настройки.
Выбор тестовой конфигурации.
Специальная настройка для тестирования рутинных операций.
Запуск теста.
Анализ времени отклика на действия пользователя.
Uddicatschemeeditor.exe: UDDI Services Categorization Scheme Editor
UDDI Services Categorization Scheme Editor (UDDICatSchemeEditor) - это инструмент с графическим интерфейсом, позволяющий создавать и модернизировать схемы категоризации, совместимые со службами UDDI. Используйте утилиту UDDICatSchemeEditor для изменения существующих схем категоризации или создавайте новые схемы и сохраняйте их в виде документа XML для последующего импорта на сайт поддержки UDDI.
Uddiconfig.exe: UDDI Services Command-line Configuration Utility
Консольная утилита UDDI Services Command-Line Configuration Utility (UDDIConfig) позволяет применять информацию, сохраненную в документе XML для настройки компонентов служб UDDI, действующих на указанном компьютере. Кроме того, пользователи смогут собирать информацию о компонентах служб UDDI и сохранять ее в формате XML. Используя предлагаемую утилиту можно настроить любые параметры, поддерживаемые консолью управления UDDI Services. При необходимости, все параметры, содержащиеся в файле применяются к компонентам службы UDDI на указанном компьютере. При сборе сведений, рабочие параметры всех компонентов службы UDDI записываются в отдельный файл.
Uddidataexport.exe: UDDI Data Export Wizard
UDDI Data Export Wizard (UddiDataExport) - инструмент с графическим интерфейсом, позволяющий выбирать сущности, поставщиков или элементы tModels, указанные в UDDI-реестре и экспортировать подробную информацию о них в файл XML.
Примечание
Сайт UDDI, с которого вы хотите экспортировать данные, должен поддерживать программный интерфейс UDDI 2.0.
Usrmgr.exe: User Manager for Domains
Утилита User Manager for Domains (UsrMgr) использует графический интерфейс для управления системами безопасности доменов, отдельных серверов домена или клиентских компьютеров в операционной системе Windows NT версии 3.51 или 4.0 с компьютера под управлением Windows Server 2003.
Предупреждение
Использование этого инструмент с доменами Active Directory или с компьютерами под управлением Windows 2000, Windows XP или Windows Server 2003 может привести к возникновению ошибок в работе, кроме того, утилита может отказаться обращаться к этим доменам или компьютерам. При работе с доменами Active Directory желательно использовать специально предназначенные для этого инструменты администратора.
Vadump.exe: Virtual Address Dump
Консольная утилита Virtual Address Dump (VaDump) поможет создать список, содержащий информацию об интенсивности использования ресурсов памяти в конкретном процессе. Благодаря инструменту VaDump вы сможете быть уверены в том, что виртуальное адресное пространство не переполнено.
VaDump анализирует виртуальный адрес выполняемого процесса. Путем настройки параметров VaDump вы обеспечите вывод следующей информации:
Данные о каждом адресе, (включая его размеры, состояние, защиту и тип).
Объем памяти, выделенной для работы с изображениями, исполняемыми файлами .exe, а также библиотеками .dll (включая системные библиотеки).
Общий объем отображенной выделенной памяти, памяти выделенной на каждое приложение и зарезервированной памяти.
Примечание
Поскольку VaDump генерирует большие объемы данных, рекомендуется сохранять выводимую информацию в отдельном файле.
Примечание
Существует множество средств обнаружения идентификаторов процессов (PID), в том числе инструмент операционной системы TaskList или Support Tool Pviewer.
Vfi.exe: Visual File Information
Инструмент с графическим интерфейсом использует ключ Cyclic Redundancy Checking (CRC) для сбора и генерирования данных о файлах. Полученная информация может быть использована в процессе тестирования для того, чтобы обнаруживать измененные файлы в разных версиях приложений или находить различия между двумя идентичными, на первый взгляд, компьютерами. Собранные данные могут пригодиться для отслеживания версий различных ресурсов, которые обычно не предусматривают сохранение подобной информации.
Volperf.exe: Shadow Copy Performance Counters
Shadow Copy Performance Counters (VolPerf) - это консольная утилита, которая позволяет администраторам использовать средство System Monitor для мониторинга процесса теневого копирования.
Volrest.exe: Shadow Copies for Shared Folders Restore Tool
The Shadow Copies for Shared Folders Restore Tool (VolRest) - инструмент с интерфейсом командной строки, помогающий обнаружить и восстановить предыдущие версии файлов в совместно используемых каталогах, защищенных функцией теневого копирования общих папок. VolRest позволяет просматривать или восстанавливать предыдущие версии файлов к которым были применены методы теневого копирования общих папок. Например, вы можете отобразить список всех предыдущих версий документа, найденных на сервере и восстановить любую из этих версий.
Vrfydsk.exe: Verify Disk
Verify Disk (VrfyDsk) - инструмент с интерфейсом командной строки, проверяющий стабильность и целостность файловой системы (FAT или NTFS) указанного раздела диска. По результатам проверки создается исчерпывающий отчет о состоянии раздела, а также отображается список обнаруженных ошибок. Инструмент VrfyDsk не в силах исправить найденные ошибки, для этого вам придется воспользоваться инструментом Chkdsk, запущенным в режиме исправления.
Winexit.scr: Windows Exit Screen Saver
Windows Exit Screen Saver (WinExit) - это хранитель экрана, который автоматически осуществит выход пользователя из системы после указанного периода бездействия. В других отношениях, инструмент является обычным хранителем экрана, который можно настраивать и проверять из панели Screen Saver в диалоговом окне Display Properties.
Winhttpcertcfg.exe: WinHTTP Certificate Configuration Tool
WinHTTP Certificate Configuration Tool (WinHTTPCertCfg) - инструмент с интерфейсом командной строки, позволяющий администраторам импортировать сертификаты и секретные ключи для использования на клиентских компьютерах.
Winhttptracecfg.exe: WinHTTP Tracing Facility Configuration Tool
WinHTTP Trace Facility Configuration Tool (WinHTTPTraceCfg) представляет собой консольную утилиту, которая позволит администратором настраивать процесс трассировки при работе со службами Windows Hypertext Transfer Protocol Services (WinHTTP). WinHTTPTraceCfg позволяет администраторам устанавливать и отображать настройки средствами командной строки, вместо того, чтобы вносить изменения в системный реестр.
Winpolicies.exe: Policy Spy
Policy Spy (WinPolicies) - инструмент с графическим интерфейсом, который позволяет просматривать и обновлять информацию о настройках групповых политик, применяемых к текущим учетным записям пользователей и локальным компьютерам.
Примечание
Инструмент располагает собственным справочным файлом. Более подробную информацию вы получите выбрав пункт «Справка» в главном меню.
Wins.dll: WINS Replication Network Monitor Parser
WINS Replication Network Monitor Parser - это динамически подключаемая библиотека, которая выполняет синтаксический анализ данных службы Windows Internet Name Service (WINS) с помощью инструмента Network Monitor. Данное средство помогает обнаруживать и устранять проблемы, возникающие в процессе репликации WINS.
Wlbs_hb.dll Wlbs_rc.dll: Windows Load Balancing Server Network Monitor Parsers
Windows Load Balancing Server Network Monitor Parsers (WLBS_hb and WLBS_rc) - это набор инструментов для синтаксического анализа данных утилиты Network Load Balancing (бывшей Windows Load Balancing Server или WLBS) с помощью приложения Network Monitor.
Инструмент WLBS Network Monitor Parsers помогает обнаруживать и устранять проблемы, возникающие в процессе распределения сетевой нагрузки. С помощью этого средства, пользователи Network Monitor смогут изучать сигналы, генерируемые утилитой Network Load Balancing (с помощью команды WLBS_hb) и осуществлять удаленное управление данными (с помощью WLBS_rc) при обнаружении подобной сетевой активности.


 route.exe

route.exe

Местонахождение

Windows\system32

Описание

TCP/IP Route Command

Эта команда нужна для редактирования или просмотра таблицы маршрутов IP из командной строки. Ключ /? выводит все доступные ключи при работе с Route.

Синтаксис


 rundll32.exe

rundll32.exe

Местонахождение

Windows\system32

Описание

Запуск библиотеки DLL как приложения - Run a DLL as an App

Windows имеет в своем составе утилиту командной строки rundll32.exe, которая позволяет запускать некоторые команды-функции, заложенные в DLL-файлах.

Вообще-то данная утилита была разработана для внутреннего пользования программистами Microsoft. Но богатые возможности этой программы дало повод на всеобщее использование пользователями.

Область применения данной утилиты довольно широк. Вы можете вводить приведенные ниже команды в окне Запуск программы (Пуск-Выполнить), также создать ярлыки с заданнами параметрами запуска, использовать в коде на программируемом вами языке (C++, Delphi, Visual Basic и т.д.)

Список команд слишком обширен. Приведем список наиболее значимых команд.

SHELL32.DLL

  • rundll32 shell32.dll,Control_RunDLL hotplug.dll - диалоговое окно Отключение или извлечение аппаратного устройства
  • rundll32 shell32, Control_FillCache_RunDLL - запустить начальную инициализацию Панели управления.
  • rundll32 shell32,Control_RunDLL - открыть в Проводнике папку "Панель управления".
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,n - вызов диалогового окна "Установка и удаление программ", в котором будет открыта вкладка с номером "n" (от 1 до 3). По аналогии при указании вместо appwiz.cpl или access.cpl другого CPL-файла будет открыт соответствующий диалог Панели управления и заданная страница диалога. Имеется несколько исключений, приведенных ниже.
  • rundll32 shell32,Control_RunDLL main.cpl @0 - открыть диалог "Свойства мыши".
  • rundll32 shell32,Control_RunDLL main.cpl @1 - открыть диалог "Свойства клавиатуры".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintersFolder - открыть папку "Принтеры" (другой способ).
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL FontsFolder - открыть папку "Шрифты" (другой способ).
  • rundll32 SHELL32,Control_RunDLL modem.cpl, add - открыть диалог "Свойства модема".
  • rundll32 shell32,Control_RunDLL timedate.cpl - открыть диалог "Дата и время".
  • rundll32 shell32,Control_RunDLL timedate.cpl,,/f - открыть вкладку Часовой пояс диалогового окна свойств времени Панели управления
  • rundll32 shell32,OpenAs_RunDLL - вызвать диалог "Открыть с помощью...".
  • rundll32 shell32,ShellAboutA WHATIS.RU - информация о версии Windows.
  • rundll32 shell32,SHExitWindowsEx 0 - закрыть все программы, перегрузить оболочку.
  • rundll32 shell32, SHExitWindowsEx 1 - выключить ПК.
  • rundll32 SHELL32, SHExitWindowsEx -1 - перегрузить оболочку Windows.
  • rundll32 shell32, SHExitWindowsEx 2 - перегрузить ПК.
  • rundll32 shell32,SHExitWindowsEx 4 - принудительно закрыть все программы.
  • rundll32 shell32,SHExitWindowsEx 8 - выход из Windows и выключение ATX-совместимого ПК.
  • rundll32 shell32,SHFormatDrive - вызов диалога форматирования диска А:.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL AddPrinter - запуск "Мастера установки принтера".
  • rundll32 shell32,SHHelpShortcuts_RunDLL Connect - запуск мастера подключения сетевого диска.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintTestPage - распечатать тестовую страницу.

URL.DLL

  • rundll32 url.dll,FileProtocolHandler %1 - открыть веб-страницу, где %1 - URL сайта (включая http://).
  • rundll32 url.dll,MailToProtocolHandler %1 - создать новое письмо, где %1 - e-mail адресата.
  • rundll32 url.dll, NewsProtocolHandler %1 - произвести подключение к новостному серверу, где %1 - URL сервера.
  • rundll32 url.dll, TelnetProtocolHandler %1 - осуществить подключение telnet, где %1 - адрес сервера.

USER.EXE

  • rundll32 user,CASCADECHILDWINDOWS - расположить все окна каскадом.
  • rundll32 user,TILECHILDWINDOWS - расположить все окна по экрану.
  • rundll32 user,disableoemlayer - сбой системы (!) - выключить все функции ввода-вывода (клавиатура, дисплей, мышь). В результате будет черный экран с курсором и ни на что не реагирующая система, однако Windows продолжает работать.
  • rundll32 user,enableoemlayer - включить и загрузить OEM Layer, если есть возможность выполнить эту команду дистанционно.
  • rundll32 user,ExitWindowsExec - быстрая перезагрузка Windows.
  • rundll32 user,RepaintScreen - выполнить команду "Обновить".
  • rundll32 user,SetCaretBlinkTime n - задать частоту мигания курсора, соответствующую значению параметра n.
  • rundll32 user,SetCursorPos - переместить курсор мыши в верхний левый угол экрана.
  • rundll32 user,SetDoubleClickTime n - задать скорость двойного нажатия левой кнопки мыши (Double Click), соответствующую параметру n.
  • rundll32 user,SwapMouseButton - поменять местами клавиши мыши (обратная смена невозможна).
  • rundll32 user,WNetConnectDialog - вызов диалога "Подключение сетевого диска".
  • rundll32 user,WNetDisconnectDialog - вызов диалога "Отключение сетевого диска".

Разное

  • rundll32 diskcopy,DiskCopyRunDll - вызов диалога "Копирование диска".
  • rundll32 keyboard,disable - отключение клавиатуры, действует до следующей перезагрузки.
  • rundll32 mouse,disable - отключение мыши вплоть до перезагрузки.
  • rundll32 krnl386.exe,exitkernel - выгрузить ядро системы, выход из Windows.
  • rundll32 mshtml.dll,PrintHTML "HtmlFileNameAndPath" - распечатать документ HTML, где "HtmlFileNameAndPath" - путь к файлу и его имя.
  • rundll32 мсprint2.dll,RUNDLL_PrintTestPage - распечатать тестовую страницу на принтере.
  • rundll32 netplwiz.dll,AddNetPlaceRunDll - вызов мастера подключения нового сетевого ресурса "Добавление в сетевое окружение".
  • rundll32 rnaui.dll,RnaWizard /1 - вызов мастера "Удаленный доступ к сети" без отображения начального окна.
  • rundll32 shell,ShellExecute - открыть Проводник (папка "Рабочий стол").
  • rundll32 sysdm.cpl,InstallDevice_Rundll - вызов мастера установки оборудования.
  • rundll32 AppWiz.Cpl,NewLinkHere %1 - запуск мастера создания нового ярлыка, где %1 - путь к исходному файлу.
  • rundll32 syncui.dll, Briefcase_Intro - вызов мастера по работе с "Портфелем"
  • rundll32 SYNCUI.DLL, Briefcase_Create - создать новую папку "Портфель", если эта функция установлена в системе.
  • rundll32 msgina,ShellShutdownDialog - вызов диалога "Завершение работы Windows".
  • rundll32 tcpmonui.dll, LocalAddPortUI - запуск мастера установки TCP-порта принтера.
  • rundll32 shdocvw.dll,DoOrganizeFavDlg - вызов окна "Упорядочить избранное"
  • rundll32 user32.dll LockWorkStation - блокировка компьютера
  • rundll32 desk.cpl, InstallScreenSaver [filename.scr] - задать файл скринсейвера в диалоговом окне свойств дисплея.
  • rundll32 IEdkcs32.dll, Clear - сброс некоторых настроек Internet Explorer, полезно использовать при некоторых сбоях в работе обозревателя.


 Службы в Windows

Службы в Windows

Ускорить работу системы, попутно освободив немного памяти, можно запретив загрузку ненужных системных служб. Отключить ненужные службы можно через оснастку Службы (Services). Здесь надо быть предельно осторожным, потому как последствия необдуманных действий могут быть непредсказуемы. Многие службы для своей работы требуют работы других служб, поэтому если Вы отключите слишком много лишнего, то можете столкнуться с такой ситуацией, что не сможете включить всё обратно. Какая служба от какой зависит можно посмотреть через закладку Dependencies из свойства службы. Но чтобы полностью избежать проблем при экспериментах со службами, мы бы советовали вам перед тем как производить эксперименты с службами сохранить ветку реестра отвечающую за запуск системных служб. Для этого в реестре найдите раздел HKLM\SYSTEM\CurrentControlSet\Serviсes.

Список служб в Windows

  • Служба шлюза уровня приложения (Application Layer Gateway Service)
Ниже мы приведём несколько служб, которые могут быть отключены. Используйте эти советы на свой страх и риск, авторы не несут никакой ответственности за возможные последствия (список служб дан для XP Pro).
  • Print Spooler: Спулер печати, ускоряет печать; если принтера нет, то его можно отключить.
  • Automatic Updates: Автоматичесткое обновление. Если у вас нет постоянного соединения с Интернетом, или если вы просто хотите контролировать всё что делает компьютер, то обновлять программное обеспечение входящее в состав XP можно и вручную. Выключая эту службу не забудьте выключить Automatic Updates в одноименной закладке System Properties.
  • Cryptographic Service: Отвечает за безопасный обмен ключами и шифрование. Используется для установки защищённых соединений, как в локальной сети, так и в интернет, играет важную роль в поддержке шифрования файловой системой. Если вам не надо шифровать файлы находящиеся на NTFS разделах, и вы не планируете использовать защищённые соединения в интернет (что использует, например, Windows Update), можете эту службу отключить. Используется она и во время проверки системных файлов (команда sfc), поэтому перед такой проверкой не забудьте включть её обратно.
  • Portable media serial number: Обеспечивает получение серийного номера переносного музыкального устройства подключаемого к компьютеру. Очередное нововведение Microsoft в рамках борьбы с музыкальным пиратством. На сегодняшний день для большинства из нас эта служба не актуальна.
  • SSDP Discovery service: обеспечивает автоматических устройств подключаемых к сети устройств, поддерживающих UPnP. Пока что это редкость.
  • Terminal Service: Раньше эта служба была доступна только в серверных вариантах ОС. Она позволяет подключаться к Вашей машине про сети, и удалёно работать на ней. В XP Pro эта служба предназначена для удаленного администрирования Вашей машины, чтобы IT специалисту не приходилось бегать самому чинить всё что Вы там натворили, а можно было сделать это удалённо. Кроме этого, через эту службу работает переключение пользователей на одной машине (Switch User). Если Вам эти возможности не нужны, можете отключить эту службу.
  • Windows time: синхронизирует время на локальной машине и сервере. Нет time-сервера - служба не нужна.
  • Messenger: Принимает и отправляет сообщения, посланные администратором. Если нет сети и администратора, то можно отключить.
  • Protected Storage: Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированный доступ. Если нет сети (в том числе Интернет), или безопасность не волнует, то данный сервис можно отключить.
  • Computer Browser: Обновляет список компьютеров в сети. Если у вас нет локальной сети, то можно отключить.
  • Server: Обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call. В случае, если у вас нет ни сетевой карты, ни модема, он вам не нужен.
  • Network Connections: Занимается управлением объектами в директории Network and Dial-Up Connections, то есть всеми сетевыми соединениями. Если нет сети, то он становится не нужным.
  • DHCP client: Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то он не нужен.
  • Telephony: Работает с модемом. Если модема нет, то он не нужен.
  • Telnet: Обеспечивает возможность соединения и удалённой работы с хостами по протоколу telnet. Если уверены, что это не пригодится, то данный сервис можно отключить.

Этот список можно ещё продолжить, необходимость того или иного сервиса определяется задачами, которые выполняются на конкретной машине, и установленным аппаратным обеспечением. Поэтому каждый должен сам решать, что можно отключить.


 SFC.EXE

SFC.EXE

Местонахождение

Windows\system32

Описание

Windows 2000 System File Checker

Утилита SFC.EXE предназначена для проверки всех версий защищенных системных файлов и восстановления их из специального кэша в случае подмены или повреждения.

В Windows XP она запускается только из командной строки - в отличие от Windows 9х, где подобная утилита имеет графический интерфейс. Запуск утилиты возможен только с правами администратора, синтаксис такой:
sfc [/scannow] [/scanonce] [/scanboot] [/revert] [/cancel] [/enable] [/purgecache] [/cache size=x] [/quiet]

Параметры командной строки, которые можно задавать для программы SFC, следующие:

  • /scannow - немедленная проверка всех защищенных системных файлов
  • /scanonce - проверка защищенных системный файлов при следующей загрузке системы
  • /scanboot - проверка всех защищенных системных файлов при каждой загрузке системы
  • /revert - восстанавливает все настройки по умолчанию (Windows XP)
  • /cancel - отменяет все проверки защищенных системных файлов (Windows Me/2000)
  • /purgecache - очистка кэша защищенных файлов программы и немедленная проверка всех защищенных системных файлов
  • /cachesize=x - установка размера кэша защищенных файлов в мегабайтах (по умолчанию 50 мГб)
  • /enable - включение защиты системных файлов Windows (Windows Me/2000)
  • /quiet - замена поврежденных файлов без предупреждения (Windows Me/2000)
  • /? - вызов справки

Давайте рассмотрим практическое применение утилиты.

Папка dllcache

Если вас не устраивает, что Windows XP занимает слишком много места и восстанавливает удалённые из его директории файлы, то может удалить папку dllcache, но после следующей проверки системных файлов Windows снова заполнит эту папку. Для устранения этого "греха", после удаления или до удаления файлов (но не папки), нужно запустить команду sfc /cachesize=число. Числом будет количество мегабайт которое должно резервироваться для папки windows\system32\dllcache. Можно поставить = 0.

Поврежденные файлы

Предположим, вы обнаружили, что на вашем компьютере отсутствуют некоторые файлы, например, шрифты (шрифты - тоже системные файлы). Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит файлы и при необходимости переустановит недостающие или поврежденные.


 Shutdown

SHUTDOWN.EXE

Местонахождение

Windows\system32

Описание

Windows Remote Shutdown Tool

Утилита Shutdown позволяет выключать или перегружать локальный или удаленный ПК, используя командную строку или специально созданный ярлык. Простой ее вызов без каких-либо параметров обеспечивает завершение сеанса текущего пользователя. Для использования всех возможностей этой утилиты необходимо задействовать параметры командной строки, синтаксис которых таков:
shutdown [{-l|-s|-r|-a}] [-f] [-m [\\Computer Name]] [-t xx] [-c "message"] [-d[u] [p]:xx:yy]

Подробнее о параметрах.
-l - завершение сеанса текущего пользователя. При наличии параметра -m последний имеет приоритет, то есть завершение сеанса производится для удаленного ПК
-s - выключить локальный ПК
-r - перезагрузка
-a - отмена выключения ПК, игнорируются все параметры, кроме -l и ComputerName. Данный параметр может использоваться только в тот момент, когда длится так называемый период тайм-аута, то есть когда программа Shutdown выделяет пользователю время на отмену своих действий
-f - разрешить принудительное закрытие всех работающих приложений
-m [\\ComputerName]- задать удаленный компьютер, который необходимо выключить
-t xx - задает временную задержку до вызова процедуры выключения компьютера в секундах - xx. По умолчанию используются 20 секунд
-c "message" - эта команда позволяет задать любое сообщение, которое будет отображаться в окне программы Shutdown. Максимальная длина сообщения - 127 символов. Текст сообщения необходимо заключать в кавычки
-d [u][p]:xx:yy - активирует некий специальный код выключения:
u - отображение пользовательского кода, p - отображение запланированного кода, xx - задает основной код (0-255), yy - задает дополнительный код (0-65536)
/? - отображает справочную информацию по программе


 sndvol32.exe

sndvol32.exe

Местонахождение

Windows\system32

Описание

Громкость - Volume Control

Данная программа позволяет управлять регулятором громкости звука

Советы

Чтобы одним щелчком открыть эту программу (а не десятью, как это предусмотрено разработчиками), достаточно создать ярлык с командой "c:\windows\system32\sndvol32.exe -rec". Эту же команду можно использовать в окне Выполнить из меню Пуск


 systeminfo.exe

systeminfo.exe

Местонахождение

Windows\system32

Описание

System Information

Выводит на экран подробные сведения о конфигурации компьютера и операционной системы, сведения о безопасности, код продукта и параметры оборудования, такие как ОЗУ, дисковое пространство и сетевые карты

Синтаксис

systeminfo[.exe] [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh]

Описание параметров есть в справке Windows


 taskkill.exe

taskkill.exe

Местонахождение

Windows\system32

Описание

Kill Process

Завершает одно или несколько заданий или процессов. Процессы могут быть уничтожены кодом процесса или именем образа.

Синтаксис

taskkill [/s компьютер] [/u домен\пользователь [/p пароль]]] [/fi имя_фильтра] [/pid код_процесса]|[/im имя_образа] [/f][/t]

Описание параметров есть в справке Windows


 tasklist.exe

tasklist.exe

Местонахождение

Windows\system32

Описание

Task List

Отображает список приложений и служб с кодом процесса (PID) для всех задач, выполняющихся на локальном или удаленном компьютере.

Синтаксис

tasklist[.exe] [/s компьютер] [/u домен\пользователь [/p пароль]] [/fo {TABLE|LIST|CSV}] [/nh] [/fi фильтр [/fi фильтр2 [ ... ]]] [/m [модуль] | /svc | /v]

Описание параметров есть в справке Windows


 taskmgr.exe

taskmgr.exe

Местонахождение

Windows\system32

Описание

Windows TaskManager (Диспетчер задач Windows)

Описание программы есть в справке Windows.

Советы

Запустить программу можно как по имени файла taskmgr.exe, так и одновременным нажатием трех клавиш (Ctrl+Alt+Del).

Откройте Диспетчер задач, дважды шелкните левой кнопкой мыши по серой области окна чуть ниже меню и она развернется на все окно. Чтобы вернуть все назад, кликните еще два раза по бортику окна.


 tracert.exe

tracert.exe

Местонахождение

Windows\system32

Описание

TCP/IP Traceroute Command

Определяет путь до точки назначения с помощью посылки в точку назначения эхо-сообщений протокола Control Message Protocol (ICMP) с постоянным увеличением значений срока жизни (Time to Live, TTL). Выведенный путь — это список ближайших интерфейсов маршрутизаторов, находящихся на пути между узлом источника и точкой назначения. Ближний интерфейс представляют собой интерфейс маршрутизатора, который является ближайшим к узлу отправителя на пути. Например, чтобы вывести трассу маршрута к http://www.microsoft.com, нужно набрать:

C:\>tracert www.microsoft.com
Запущенная без параметров, команда tracert выводит справку

Синтаксис

tracert [-d] [-h максимальное_число_переходов] [-j список_узлов] [-w интервал] [имя_конечного_компьютера]

Описание параметров есть в справке Windows


 wscript.exe

wscript.exe

Местонахождение

Windows\system32

Описание

Microsoft (r) Windows Based Script Host

Сервер сценариев wscript.exe является GUI-вариантом, предназначенный для взаимодействия с пользователем через диалоговые окна Windows (в отличии от консольного приложения cscript.exe). С помощью сервера сценариев можно изменять реестр без вывода диалоговых окон, удалять и создавать файлы, многое другое.

Уникальная возможность - можно удалить файл скрипта до завершения его работы. То есть, скрипт сидит в памяти, а самого файла уже давно нет. Используя эту возможность можно создать так называемый скрипт-призрак.

Чтобы запустить написанный скрипт, можно просто дважды щелкнуть левой кнопкой мыши по нему в окне проводника. При этом сценарий запустится с настройками по умолчанию. Чтобы сценарий работал с другими параметрами, нужно в командной строке указать имя сервера сценариев, имя самого сценария и параметры запуска.

Синтаксис

wscript имя_сценария.расширение [параметры...] [аргументы...]
Чтобы получить полный список параметров, используйте wscript /?

Однако, такой вариант запуска изменит параметры по умолчанию для всех запускаемых впоследствии сценариев. Если в этом нет необходимости, есть возможность задать свои параметры для каждого отдельного файла сценария, более того, можно задать несколько вариантов запуска одного и того же сценария. Для этих целей служит файл с расширением wsh. Он представляет собой обычный текстовый файл и по своей структуре очень похож на inf или ini файл. Чтобы создать простейший *.wsh файл откройте свойства любого скрипта и на вкладке "Сценарий" измените любой параметр. После нажатия на "OK" в том же каталоге появится файл с аналогичным именем и расширением wsh. Вот пример одного из таких файлов:

[ScriptFile]
Path=G:\files\p010.js
[Options]
Timeout=0
DisplayLogo=1

В секции [ScriptFile] есть только один параметр - Path, который указывает на запускаемый скрипт, в секции [Options] перечисляются параметры для запуска этого скрипта.

Если теперь запустить созданный нами файл, он будет выполняться с настроенными параметрами.

Возможность указания параметров при старте сценариев является, безусловно, очень полезной и позволяет более тонко контролировать процесс работы скрипта